0
$\begingroup$

I'm pulling hairs over this. The keyframes for my object show up in the dopesheet but not in the timeline and the graph editor. I have selected the object, tried every other options like view selected frames, the home key, the period key, zoomed out, the little arrow button that show only selected. Nothing. It doesn't even make sense how the keyframes appear only in the dopesheet and not others for the same object.enter image description here

$\endgroup$
1
1
$\begingroup$

The keyframes you're looking for are Grease Pencil Keyframes, and they have their own interface, which is the dopesheet grease pencil panel.

In the timeline, ordinary dopesheet and graph editor will appear only for keyframes related to the Grease pencil object as a whole, while those of yours are related to every single vertex of GP strokes, and they are not editable in the graph editor.

When you create the interpolation between two extremes, you can choose between linear, the preset of easing in and out, or even define a custom curve of interpolation.

enter image description here

$\endgroup$
2
  • $\begingroup$ Thank you for the response. So, I followed your comment and tried the custom curve and other options but the changes don't show in the animation at all. (I'm a noob, btw). $\endgroup$ – Peregrine May 4 at 4:06
  • 1
    $\begingroup$ For better understanding, try this procedure: on frame 1 create a circle; go to frame 20, go to edit mode and grab the circle in another location. Then set the timeline cursor anywhere between frame 1 and 20 and, in edit mode, go to the interpolate menu, select custom, define a custom ease in/out curve and press "sequence". It will create all 18 inbetween frames following the ease in and out defined by your interpolation curve. $\endgroup$ – josh sanfelici May 4 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.