0
$\begingroup$

I used the same texture for all these meshes, but why does the "footboard" have a different color (red arrow)?

enter image description here

I'm now working with 2.92 but started with 2.79, could that be related to it?

Also, I have a strange "reflection" when I rotate only on the rear fender / rear fender.

Strange "reflection"

unfortunately, all linked answers did not help.

Blend file:

$\endgroup$
3
  • 1
    $\begingroup$ Try this: Vertex Group, normals and check auto smooth $\endgroup$
    – Artichoke
    Commented May 2, 2021 at 16:00
  • $\begingroup$ i updated my answer. $\endgroup$
    – Chris
    Commented May 5, 2021 at 13:16
  • $\begingroup$ Although this is not the answer (which @Chris will give here soon), I'dd like to add that the shading and smoothing in Material Preview mode might not always be exactly like it looks in Rendered View afterwards. Even before finding the solution I could get it look similar in Rendered View when there still was a problem in Material Preview. Oh, adding my own HDRI to the scene it was upside down - when using Environment Texture with Texture Coordinate and Mapping node, you better use the "Generated" output instead of "Normal". If you need it flipped, set X or Y rotation to 180°. $\endgroup$ Commented May 5, 2021 at 14:27

1 Answer 1

2
$\begingroup$

UPDATE: you should try Gordon's proposal - he is an experienced PRO Blender user - i just started using Blender a few month ago...so scroll down to his professional answer.

repair your face orientation like this:

mesh -> normals -> recalculate outside

enter image description here

UPDATE:

i know, the "moderators" here are very fast with closing questions although they appearantly didn't check your blend file.

I never saw something like this, but i found a "workaround" for you.

Check this video how you can "repair" it.

https://youtu.be/UyEyzjV2r9k

Essentially you can at least improve it by adding some loop cuts at the right positions.

So here is Gordons answer:

Solution is quite easy, the darker part has some "thickness" to it and smoothing goes around the edges. Not even deleting the solidifying faces helps. Autosmooth would normally take care of that, but if you enable it you see the "30°" is greyed out. That's because there is some custom Geometry Data on the object. Click on Clear Custom Split Normals Data to remove it and Autosmooth works as expected. I've made some screenshots for explanation, too. –

enter image description here

$\endgroup$
1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .