I'm trying to add fire+smoke to a video by rendering out the simulation as a PNG sequence with transparency. It looks fine in the render window and in the compositor but when I drag in the final PNG and view it, it looks half transparent and grainy. I'm only rendering it on 15 samples with NLM de-noising on so that could be it, but otherwise I'm not sure what's going on! here are some screenshots: this is it in the render window, looking how i want it

this is it in the compositor, also looking how i want it

but this is the png, the fire is translucent and extremely grainy

rendering on GPU, 15 samples and transparency enabled (also transparent glass)

its a PNG with RGBA enabled

  • 1
    $\begingroup$ PNG is a broken format. Use EXR in Blender. $\endgroup$
    – troy_s
    May 2, 2021 at 13:44
  • $\begingroup$ please provide blend file $\endgroup$
    – Chris
    May 2, 2021 at 15:36

1 Answer 1


Use denoise node in compositing instead of the one you are using. It is better for viewports only.

To use denoise node,go into the compositing tab and SHIFT+A to add denoise node. Now add color,normal and albedo in their respective channel.

To get better results,enable denoising data from the layer settings.

Disable the denoiser you are using and it will give better results

  • $\begingroup$ Hi, thanks for the post. This site is not a regular forum, answers should be substantial and thoroughly explain the solution and required workflow. One liners and short tips rarely make for a good answer. If you can edit your post and provide some more details about the procedure and why it works feel free to restore it, otherwise it may be deleted or converted into a comment. Perhaps add a few images illustrating the workflow and final results. See How do I write a good answer? $\endgroup$ May 2, 2021 at 22:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .