So, I have been trying to make a Jett's knife model in Blender. Everything was fine until I tried to cut a hole in the knife. Since I have only been using Blender for like 5-6 days only, I searched for some ways to do that. I found that I needed to use a Boolean Modifier, so I did. I selected the knife, and the cube that I edited into the shape of the blade. But, when I selected the cube in the "Object" part of the modifier, it removed the blade instead. I don't know why this happens, maybe I did something wrong. I tried to follow other things on the Internet but it still failed. How can I fix this?

I was expecting the circled part to be cut out. But it cut the outside instead.enter image description here

https://youtu.be/qV_g0ASsFHo Here is what I did

  • 1
    $\begingroup$ Maybe try Solver > Fast instead of Exact in the Boolean modifier. If it still doesn't work, maybe share your file? pasteall.org/blend $\endgroup$
    – moonboots
    Apr 28, 2021 at 12:31
  • $\begingroup$ Do you know where the solver is? I can't seem to find it I uploaded the file, you can give it a check. $\endgroup$ Apr 28, 2021 at 12:45
  • $\begingroup$ in the modifier > Solver > choose Fast, not Exact. About the file: you need to share the link ;) $\endgroup$
    – moonboots
    Apr 28, 2021 at 15:00
  • $\begingroup$ It turns out that you have bad geometry in your 'cutter' cube. Fixing that and applying the boolean to both objects fixes it. See my answer. $\endgroup$ Apr 30, 2021 at 15:36

1 Answer 1


I've had a chance to look at the actual blend file, and I found geometry problems. Let me show you how I found and fixed one.

I took your Cube cutter into edit mode in a local window. (If you have a number pad on your keyboard the / character on the pad toggles that mode.)

Then I used the select menu to select interior faces

selecting interior faces

Turns out you've got one:

interior face on cutter

That's going to confuse the boolean operator, so delete it. Use the X key and select "Faces".

It still doesn't work because you have two objects you need to apply the Boolean to, "Blade" and "Middle Knifu"; so I added the boolean to each.

and it worked

and it worked.

ASIDE: You have a lot of bad geometry in both the blade and Middle Knifu. In addition to interior faces you have duplicated vertices and you have interior edges.


Be sure that you apply the Boolean modifier to the cube that represents the blade and not the object you are using to 'cut' the hole. Here's a crude example:

"blade" with hole

What you don't see in the example is the cylinder I used as the 'cutter' object. If you look at my scene collection you'll see why:

scene collection showing cylinder is not visible.

When you select the blade and go to the modifiers panel, the Boolean modifier should look like this:

boolean modifier to make hole

Notice that the modifier is applied to the blade and that the "Object" in the modifier is the cylinder.

Below the Object there's a 'Solver' box. I have it set to Fast.

A common rookie mistake is to apply the modifer but leave the cylinder visible. If you do this it looks like nothing happened:

Cylinder is visible

There are a couple of ways to solve this. For the example I simply made the Cylinder invisible:

Cylinder invisible in 3D view space

If you do it this way, the cylinder will still show up in renders. You have to also make it invisible to the camera:

cylinder invisible to camera

Alternatively, if you are going to use a lot of Booleans a better technique is to move the cylinder to a new collection, usually called 'cutters':

Select the cylinder and type M. this will bring up a menu:

move menu

Since you don't already have a collection, select "new collection" and give the collection a name.

moving to new collection called 'cutters'

Now all you have to do is uncheck the box for the cutters and the cylinder won't show up in the 3D view or on a render:

cutters collection disabled

  • $\begingroup$ Soo, I did what you said. I selected my blade, added the Boolean Modifier, choose the "cutter" cube, chose Fast, and I hid the "cutter". But..., It's still not working. Am I doing anything wrong again. Here's the file of the knifu: pasteall.org/blend/ec34ba87127b43998ca32c8b33412ab5 Here's the video of what i did: youtu.be/f_KNWTVbNMs $\endgroup$ Apr 29, 2021 at 4:48
  • $\begingroup$ I can't download your blend file because pasteall is giving me a 'file not found', but looking at your video it looks like your cutter cube isn't big enough to go all the way through the knife body, and that's confusing the boolean. Otherwise you've done the right thing. Can you try again on the paste? $\endgroup$ Apr 29, 2021 at 19:58
  • $\begingroup$ pasteall.org/blend/7c0efd330c194be98e746ff18a3227c4 $\endgroup$ Apr 30, 2021 at 7:46
  • $\begingroup$ Got that version, and you've got bad geometry that is causing the boolean operator to be confused. I'll write an answer shortly. $\endgroup$ Apr 30, 2021 at 15:24
  • $\begingroup$ All right. Thx btw $\endgroup$ May 1, 2021 at 7:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .