0
$\begingroup$

I’m using a particle system to place rocks on a terrain. Despite playing with every setting I could think of to resolve the problem, I can’t stop many of the rocks from floating above the ground. The particles are last in the modifier list, and I even have “use modifier stack” enabled in the particle emission settings to guarantee the updated geometry should be used.

I believe this occurs most when child particles are used. I'm using interpolated children which to my knowledge are aligned to the mesh surface thus shouldn't be producing this problem. I need child particles as they're the only way to achieve proper clumping (groups of little rocks scattered in various points), if I use just parent particles each individual rock is placed at random without any pattern.

Also please don't direct me to use geometry nodes: I'm aware they exist and they're definitely an exciting feature, however the latest implementation is still in early stages and constantly changing around a complex attribute setup. Once it becomes reliable I may go for those nodes, but in the meantime I'm still using particles for terrain details such as grass.

Here's a simplified version of my blend containing just the terrain with particle rocks. As can be seen in the screenshot the rocks tend to float quite a bit above the surface.

https://pasteall.org/blend/1782c65576eb4d9fb4bb6f09ad957717

enter image description here

$\endgroup$
0
$\begingroup$

It's definitely related to the modifiers, or clumping.

One option is to apply the modifiers, which seems to ground the rocks. You might not want to do that.

The other thing seems to be Clumping. If you set it to a positive value it seems to not float, but I think the clumping just pulls together the particles in space without regards to the modifier stack of the surface they're sitting on, unfortunately. The only thing I could figure out that doesn't break the clumping was applying the subsurf and displace.

$\endgroup$
3
  • $\begingroup$ But if I enable "use modifier stack" on the particles, shouldn't that put the particles on the updated geometry and avoid all modifier issues? Just in case though I tried applying the Subsurf and Displacement modifiers: This changes the rock patterns but the boulders still float. The issue does however appear to be related to clumping being set to a negative value, a positive one will solve it! The problem is that this also makes child particles no longer stick close to the parent ones which is the reason I was using that. $\endgroup$ – MirceaKitsune May 11 at 14:24
  • $\begingroup$ From what I could tell, "Use Modifier Stack" works if you don't use Clumping. Clumping seems to just pull them together directly with no regard for anything else. Yes, positive values seemed to work fine but doesn't give the kind of grouping you wanted. :/ $\endgroup$ – Dale Cieslak May 12 at 2:01
  • $\begingroup$ Is there any alternative for what I want via particles? Meaning to have the little rocks (child particles) gathered around the main ones (each parent particle), of course without the issue of floating though. I tried other options such as parting or virtual parents however none seem to do this. $\endgroup$ – MirceaKitsune May 13 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.