0
$\begingroup$

I'm using ColorRamp to limit the colors of my render to only a couple of colors. In the outputted image, there are still slight variations of the colors set in the ramp and I can't get them to stop appearing.

As an example, I have this basic scene and composition nodes: Composition nodes

The colors in the ramp are #FF0000, #00FF00 and #0000FF. I would expect to get an output containing only those colors, but if I pick colors in it, I find:

  • #FF0000, #00FF00 and #0000FF which is right
  • Variations of red #FF0101 and #FE0000
  • Variations of green #01FF01 and #00FE00
  • Variations of blue #0101FF and #0000FE

How can I remove those additional colors from the render? I want the final color palette to contain only the exact colors I picked. Of course in my actual files, there are other colors too but this little example alone reproduces the problem.

Also, my Color Management settings are set like this:

Color management settings

Any idea?

My example file if you want to try (you will need a color picker):

$\endgroup$

1 Answer 1

0
$\begingroup$

I got it. I noticed that this happened even with only a #FF0000 background without any object on it, checked every possible option, and found a culprit: Output properties > Post-processing > Dither. I switched it to 0, and no more color variation. The only problem left is that colors are not always the exact ones, but they are always the same variation at least. #00FF00 becomes #01FF01, but it's always that, which is far better.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .