1
$\begingroup$

I made an eye and for texturing I used a procedural approach. It looks fine when the character is in rest position, however when in pose position the whole eye turns red (the materials don't work well anymore?). The file can be downloaded here: https://www.dropbox.com/s/oy4utqa1l0grppk/blendstackexhange.blend?dl=0
I have 2 materials: one for the sclera and one for the iris. The shape of the eye is the following(the selected part is the iris):
enter image description here

Material preview in edit mode:
enter image description here

Is there a fix for this? Here is a picture of the eyes in rest and pose position: enter image description here

EDIT:
Here is my node setup:
The iris:
enter image description here

And the sclera:
enter image description here

$\endgroup$
8
  • 1
    $\begingroup$ can you provide your blend file? $\endgroup$
    – Chris
    Apr 25 '21 at 16:31
  • 2
    $\begingroup$ This is because you are using a texture coordinate system that does not follow the mesh. Try using UV texture coordinates: procedural textures can use them. $\endgroup$
    – TheLabCat
    Apr 25 '21 at 16:32
  • 2
    $\begingroup$ It would help if you posted a screenshot of the material setup for the eyes $\endgroup$
    – Gorgious
    Apr 25 '21 at 16:34
  • $\begingroup$ I edited the question with more info and the blend file (I couldn't upload it directly here). If you could take a look again please. How can I use UV for procedural textures ? $\endgroup$
    – qwerty2121
    Apr 26 '21 at 6:18
  • $\begingroup$ You have to UV Unwrap your object and in the Shader Editor use the UV socket of the Texture Coordinate node instead of Object. If you have never used UV maps there is quite a lot to say about it, too much for a short comment here. But there are loads of tutorials on UV unwrapping. $\endgroup$ Apr 26 '21 at 8:09
0
$\begingroup$

if you uncheck this (bind to vertex groups), it works. Although i am not sure whether you need this... ;)

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.