10
$\begingroup$

I'm new to blender (v2.92.2) and would like to know how to prevent the water from getting to the boat. I have used an Ocean Modifier over a plane to create the ocean and modelled the boat. enter image description here

When I use the difference bool tool by selecting the boat first and then the ocean, the boat disappears. enter image description here

When I use the difference bool tool by selecting the ocean first and then the boat, the ocean and part of the boat disappear. enter image description here

Should I be using something different?

enter image description here

$\endgroup$
2
  • $\begingroup$ Can u provide your blend file? $\endgroup$
    – Chris
    Apr 24, 2021 at 8:42
  • $\begingroup$ Since answered, just a note to the "disappearing"... BoolTool > Auto Boolean automatically deletes the differenced object (boat) ... in case Bool Tool > Brush Boolean - automatically change Viewport Visibility to type Bounds ... you can make it visible back in Object Properties > Viewport Display $\endgroup$
    – vklidu
    Apr 24, 2021 at 21:02

2 Answers 2

10
$\begingroup$

You need to create a proxy mesh which you will not be rendering, that encompasses the body of the boat, then add a boolean modifier set to difference to the ocean and set to use the proxy mesh.

Example :

enter image description here

I duplicate the bowl object, increase the mesh's size so there is overlap in the bottom of the bowl.

enter image description here

Then select the ocean object, add a boolean modifier. Don't forget to set the solver to Fast, the Exact solver is pretty buggy.

enter image description here

Don't forget to parent the proxy mesh to the boat object so that it moves with it, and uncheck all the render properties for the proxy so it doesn't show up in rendered view.

enter image description here

$\endgroup$
6
  • $\begingroup$ Dang! 7 minutes behind with an identical answer ! >8-|| $\endgroup$
    – Robin Betts
    Apr 24, 2021 at 9:22
  • $\begingroup$ @RobinBetts Wups ! You should have let it up and let the crowd decide which one they prefer :) I personaly don't mind at all $\endgroup$
    – Gorgious
    Apr 24, 2021 at 9:35
  • 2
    $\begingroup$ Hehe.. not enough difference :) The objective is to help readers, not to win competitions. $\endgroup$
    – Robin Betts
    Apr 24, 2021 at 9:39
  • $\begingroup$ Thank you that worked, with the ocean showing some quirks though! Reference image. $\endgroup$
    – Kannan
    Apr 24, 2021 at 12:55
  • $\begingroup$ @Kannan you can solve it by enabling auto smooth in the mesh properties, or just adding a solidify modifier should do the trick $\endgroup$
    – Gorgious
    Apr 24, 2021 at 13:39
4
$\begingroup$

Instead of a Boolean you could try using a Shrinkwrap modifier on the Ocean - set to 'Project' - to move the vertices to the under-surface of the boat.

  • Select the Ocean and add a Shrinkwrap modifier
  • Set the Method to 'Project'
  • Set the Axis to 'Z' and enable Negative
  • Set the Target to your boat
  • Ensure the Shrinkwrap is after your Ocean modifier in the modifier stack
  • Adjust the Offset to fine-tune the intersection

Note that you need to ensure your ocean has sufficient geometry.

$\endgroup$
1
  • $\begingroup$ Thank you, that worked too, but again ocean is showing some quirks! Reference Image. $\endgroup$
    – Kannan
    Apr 24, 2021 at 13:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .