1
$\begingroup$

Been touching upon EEvEE every so often depending on what kind of image quality I'm looking for at the moment, and for the first time I am adding smoke. More specifically Glowing Smoke, as in "Magic". However, the volume material shows through other objects in front of it.

enter image description here

You can see more clearly on the right the yellow magic outlines the entire horn, even the part that is embedded into the skull and hiding behind the hair. I have played around with the material's Blend and Shadow Modes, Refraction and Subsurface Translucency, and all the settings connected with Volumetrics (and Shadows), but it does not seem to make a difference. Anything I am missing or is this a bug?

Blender 2.92.0 2021-02-24 16.25

EDIT I made a new project with nothing in it, I imported the right model, and applied the smoke on the horn, and brought up the Emission Strength only. The whole thing still shone through.

EDIT2 When putting in the ordinary geometry from the Add menu and shaping them approximately to the model, the smoke is occluded.

$\endgroup$
2
  • $\begingroup$ Share blend - smoke+hair only if issue persist ... $\endgroup$
    – vklidu
    Apr 23 at 16:01
  • $\begingroup$ @vklidu Here is the blend, no bakes, all domains set to Replay. Still big tho. edwardleuf.org/x/intro2b.zip $\endgroup$
    – Edward
    Apr 23 at 19:47
1
$\begingroup$

You can try this file (2.93) or try with some new file to eliminate something specific to your issued file.

Left Smoke sim / Right only Volumetric material ... both seems to be working.

enter image description here


Edit

That was real issue hunting ... the main reason is this Question ... for Eevee it is too small step in depth when volumetric is calculated. And I'm not sure there would be solution for you. Here is example with solved issue ...

enter image description here

enter image description here

enter image description here

... but the only one solution I found ... crop the area under Render Properties > Volumetrics > Start/ End and increase Samples up to 256 ... also don't use Distribution around 1, use some low value.

enter image description here

That means very limited range of volumetric effect depend on Camera distance.

Your file has other things that can cause some issues ... like extremely high Viewport Clip End that generates flickering, some of your objects like unicorn's hair use wrong Normals direction, and it is always better to have Applied Scale for all objects if possible ... not the case for volumetric issue, but any time I tried to switch to Eevee all computer crashed that never happened for many years to me.

Here is a file in condition that I expected you will share (hair+horn) that takes only 0.6 MB.

If you are looking for just an effect like glowing horn, you can use new object type Volume with Mesh to Volume modifier instead of Smoke simulation ... or even easier animate emission material for horn with some high value and enable Bloom in Render Properties.

$\endgroup$
3
  • $\begingroup$ Well, can't figure it out. I've tried to make your file mimic mine and visa-versa but the results don't seem to change in either (yours is blocked and mine isn't). I even made a new file, imported the model above, applied the smoke and it shines through. $\endgroup$
    – Edward
    Apr 23 at 13:52
  • $\begingroup$ You are saying that my file opened on your PC is OK? Try "Load Factory Setting" ... $\endgroup$
    – vklidu
    Apr 23 at 15:56
  • 1
    $\begingroup$ Ah, there we go. Clipping. I always forget about that. Most often I set these things as close and as far as possible, but only if I have a large environment. And I know I can use Emission or static volumes, but I do want that little variance that comes with smoke simulations. Anyways, thanks. $\endgroup$
    – Edward
    Apr 24 at 0:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.