0
$\begingroup$

I am focusing on character animation this week, and have a object that was not rigged in Blender files. So I decided to rig it myself.

I had great success on MOST of the body. However the mouth area is not working properly.

I did a re-rigging using Rigafy, and still no movement. Everything else works as expected.

I am attaching the Blender file as well. Normally I end up answering my own questions, but this one has me stymied.

The selected regions have no affect on the mesh

$\endgroup$
2
  • $\begingroup$ Have you used "Parent with Automatic Weights"? The lips work with this. You just need to add 4 bones at the bottom of the eye to limit the lip bone's influence. $\endgroup$ – Blunder Apr 22 at 21:17
  • $\begingroup$ Okay when I first set up the rig, I used Parent with automatic weights. However, you did something that worked (thank you). I can add 4 bones at the bottom (what should they be added from). In addition, you suggest parenting. what do I use as the lip bones parent? I will play around, but then look at your feedback. $\endgroup$ – CJBPMP Apr 22 at 21:21
1
$\begingroup$

Okay, thank you Blunder for pointing me in the right direction.

The issue is I added the lips and what-not AFTER I did the original parenting of armature to mesh.

I assumed (incorrectly) that generating rig would reparent. It did not. Reapplying the rig using rigafy did not, as I thought, recreate the parenting. I needed to do both. I will figure out the extra bones shortly. Thanks.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.