3
$\begingroup$

enter image description here

Hi! This is something that bothers my a lot of times. I always end up creating a volume mesh instead of a plane with the solidify modifier to solve the problem but I was wondering if there is a way to solve this in an easy way. Now I'm working in the wall of a house and I modeled it using a plane an extruding some of the edges, but now the textures of the sides of the windows are all wrong... Thank you!

$\endgroup$
5
  • 3
    $\begingroup$ I think you should watch some tutorials about UV Unwraping. This is a UV stretch problem. You will have to add more seams. $\endgroup$ Apr 22, 2021 at 8:17
  • $\begingroup$ My problem is that the object is a plane with Solidify modifier, and I was wondering if there is a way to UV unwrapp the edges of an object with solidify modifier. $\endgroup$
    – Artichoke
    Apr 22, 2021 at 10:00
  • $\begingroup$ I will try to find a solution for that if I can. $\endgroup$ Apr 22, 2021 at 10:01
  • $\begingroup$ Thanks for your help!! :) $\endgroup$
    – Artichoke
    Apr 22, 2021 at 10:08
  • $\begingroup$ I jsust found a new solution to stop UV's from stretching with solidify modifier. I'll update my answer. $\endgroup$ Apr 22, 2021 at 15:26

2 Answers 2

2
$\begingroup$

As @Chaudhry Yousuf suggests, you need to unwrap your mesh and apply your texture using its UV map.

You can find more info about UV map on the BlenderGuru's Youtube channel : here, or here

$\endgroup$
2
$\begingroup$

Here I have an extruded plane:enter image description here The problem you are facing is because your UV's have stretch. To rremove it, you need to add seams. For this simple object, go to edit mode, hit 'A' on your keyboard to select your whole mesh, then hit 'U' and then click mark seam. You will see a red outline on your mesh, which shows a seam. Then again hit 'A' on your keyboard to select your whole mesh, then hit 'U' and then click Unwrap. Your stretching will go away.enter image description here

Edit: If you want to keep the solidify modifier, then do this:

Open the shader editor and add a texture coordinate node to the material of your plane. Then drag the generated input to your vector input in the image texture. Then just set the settings from flat to box on the image texture node. It works.enter image description here

$\endgroup$
2
  • $\begingroup$ Thank for the answer! But my problem is that the object is a plane with Solidify modifier. So I don't have the option to mark the two "squared" seams that you have marked, only the one of the original plane. $\endgroup$
    – Artichoke
    Apr 22, 2021 at 9:04
  • 1
    $\begingroup$ @Artichoke So then you can apply the solidify modifier or avoid to show those stretched UV's in your render. $\endgroup$ Apr 22, 2021 at 9:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .