5
$\begingroup$

In Blender 2.92, I'm trying to simulate a thin liquid, like a syrup, running down a soft ice cream cone, like the picture attached (ice cream in glass jar)target fluid

best attempt so farThe closest I got is on the second picture. The liquid is too thick, not in the sense of too viscous, but the thickness of the run out is too thick, it should be thinner, like a syrup, less like melted choc or honey. I tried to reduce viscosity, but the thickness remains the same. I tried reducing the size of my inflow object (cylinder), but now i'm at the minimum, below that, it won't flow out of the cylinder. I'm not sure which other parameters I can play with. The liquid should stick and spread more, but here it kind of lumps together.

My settings(particle radius was 1 in my picture, not 1.9): enter image description here enter image description here

Edit 22.4: following proposal below, I have changed the resolution from 32 to 64. It's going in the right direction, see picture below. But processing time jumps from a few seconds to more than 20 min, for a simple scene like this. So I hesitate to crank up to 128. The liquid is still voxelized. I need to find a way to continue to improve without exploding processing time. Any idea ? Can I reduce the scale of my objects ?

enter image description here

$\endgroup$
1
  • $\begingroup$ Unfortunately, there is no other solution. Good images are very time-consuming. Everyone faces this problem. The only other solution is buying better hardware. $\endgroup$ – Chaudhry Yousuf Apr 22 at 10:05
9
$\begingroup$

The answer looks simple: the resolution of the domain is set to 32, which is very minimal. Turn this resolution up to get more voxels, and thus more precise fluids.

$\endgroup$
7
  • 1
    $\begingroup$ I've updated my initial post with the result using resolution = 64. It's going in the right direction, but processing time is exploding (using Titan XP GPU), something i'm not doing right. $\endgroup$ – Hugues Apr 22 at 10:03
  • $\begingroup$ As far as I know the fluid simulations are running on CPU, so a good GPU will only help with the rendering afterwards. And even there simulations are quite time consuming. $\endgroup$ – Gordon Brinkmann Apr 22 at 10:17
  • $\begingroup$ resolution 64 is starting to give good results, but takes >20 min to process. Could I reduce the processing time by scaling down my objects ? I'm asking because I initially scaled up my ice cream cone to 6.5meters (yes meters) because I could not get the liquid to flow out of my cylinder when the objects were at normal scale. If you tell me that processing time will reduce, then I will scale down to normal scale and find a solution for the liquid to flow out of a small cylinder, say 1 cm for example. $\endgroup$ – Hugues Apr 22 at 11:18
  • 1
    $\begingroup$ No, the scale doesn't matter. A resolution of 64 means the voxel size is so that it fits 64 times into the domain's largest dimension. If the domain is 1 or 10 meters doesn't make that much of a difference, only the voxels will be larger but not more precise. Do you have a cube (= all dimensions same size) as domain or a cuboid stretch in Z direction? Since you don't need that much space to the sides, reducing the overall volume decreases the absolute number of voxels, maybe this helps a little... for smoke simulations there is Adaptive Domain, but this option is not available for liquids. $\endgroup$ – Gordon Brinkmann Apr 22 at 12:53
  • 1
    $\begingroup$ ok i see. My domain is a cylinder around the ice-cream cone, the cylinder is longer than its Diameter, so I will try to reduce the size of my domain as much as possible. Thanks. $\endgroup$ – Hugues Apr 22 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.