0
$\begingroup$

I want to continuously rotate a planet. It works in minimal practice projects. Here is what I did:

  1. Toggle Camera view
  2. Make final frame 90
  3. press record
  4. press I on highlighted object and select rotation for frame one and frame 90.
  5. set Z axis for frame 90 to 360 degrees.

In the actual project the toggle camera view does not work. It does not show the whole object in the camera view. it only shows a quarter of the planet. I am not sure if that is the problem. If I apply all those above steps to the project, there is no rotation no movement at all. I have no experience rotating objects. All objects are just spheres with textures.

$\endgroup$
2
  • 1
    $\begingroup$ The parts that are missing might be due to camera clip end distance. There are 2 places to adjust this - one for the viewport camera and one for the scene (render) camera. For the viewport camera, press N in the viewport and select the view tab from the right side of the menu that appears. The clip start and end values are at the top. For the scene camera, select the camera object, and then select the object data properties tab (on the right) . The values are in that tab. For the animation, I think you need to keyframe at the start (frames 0 and rotation 0) as well as at the end frame. $\endgroup$ Apr 20, 2021 at 22:18
  • $\begingroup$ What do you mean on step 3, "press record"? You mean enabling the Automatic Keying function? That is not necessary if you set keyframes with "i" (in the worst case it could even overwrite your inserted keys with accidentally made changes). But for the rotation you need two keyframes, one for the start and one for the end. $\endgroup$ Apr 21, 2021 at 7:59

1 Answer 1

1
$\begingroup$

In the timeline, go to the first frame of the animation, rotate the object to the desired starting rotation (0 in Z axis). With the object still highlighted, hit "i" and select 'rotation' to set the keyframe. Go to the last frame of the animation, rotate the object to the desired end rotation (360 in Z for a full rotation). With the object still highlighted, hit "i" and select 'rotation' to set the keyframe.

You have to set both keyframes, or else blender will reset the rotation and will not animate.

$\endgroup$
3
  • 3
    $\begingroup$ I would suggest, since the question opens with "continuously rotate a planet", that if the animation is running from frame 1 to 90 you better go to frame 91 and set a keyframe for 360 degrees or otherwise will seem to pause for a moment. And with all keyframes selected in the timeline hit T, then Set Keyframe Interpolation > Interpolation > Linear, because by default the interpolation is set to Bézier which will not result in a continuous uniform rotation speed. $\endgroup$ Apr 21, 2021 at 7:52
  • $\begingroup$ Yes, you're right. $\endgroup$ Apr 21, 2021 at 14:52
  • $\begingroup$ Thank you, I have tried all of these suggestions but I still cant seem to get the darn thing to rotate. I know I am missing a setting or something somewhere. I will keep picking at it thank you all!! $\endgroup$ Apr 26, 2021 at 14:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .