0
$\begingroup$

I have a problem where no matter what I do Blender utilizes my CPU instead of my selected GPU.

I have a fairly older CPU and a much stronger newer GPU - RTX 2060, that's why I want to utilize it.

I tried everything but I can not find the solution. I am using Blender 2.92 I enabled CUDA ( Also tried OptiX - did not work) in my preferences, checked the compatibility and selected my GPU. Cycles is selected with GPU compute I tried reinstalling blender several time with no change. No matter what I change whenever I try to render a liquid simulation for example, my CPU usage is 100% and my GPU is 0%.

I have no idea what else to do.

EDIT 1: Checked again in task manager specifically CUDA and not general GPU and it remains at 0%

EDIT 2: Problem was, I'm just stupid and did not realise you exclusively use CPU for physics.

$\endgroup$
4
  • 1
    $\begingroup$ Hello :). Simulations are only calculated on CPU (and often single threaded). GPU is used for rendering and viewport. $\endgroup$ Apr 17, 2021 at 16:57
  • $\begingroup$ I did not know that, I thought that if GPU is selected that it can run physics as well. Thank you for the help. $\endgroup$
    – Skafandr
    Apr 17, 2021 at 17:13
  • $\begingroup$ GPU render works fine in the end. All of the aforementioned things are adjusted right. $\endgroup$
    – Skafandr
    Apr 17, 2021 at 17:15
  • $\begingroup$ No problem :). This is specific to Blender. Other software (like Houdini) will happily run physics on a GPU :) $\endgroup$ Apr 17, 2021 at 18:02

1 Answer 1

2
$\begingroup$

It might be that you looking the performance of integrated gpu, that's why it shows 0%. In task manager make sure you are looking the stats of your dedicated gpu. Also change graph to cuda enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .