2
$\begingroup$

enter image description hereif I have set Motion Blur for rendering and deactivate it for a certain object in the object properties, the object is still blurred. The scene is a tracking shot from behind towards a boat that is cruising on the water. Motion blur should only be used on the water. I would be very happy for any help! I use Cycles for Rendering.

Kind Regards, Tim

$\endgroup$
4
  • 1
    $\begingroup$ It could be the camera's motion blur. If that is the case, you will likely need to render separate sequences and recombine them to totally kill the motion blur on one object. $\endgroup$
    – HISEROD
    Commented Apr 17, 2021 at 15:14
  • $\begingroup$ Hmm I have a lot of scenes overall. And to render everything twice wouldn't be very nice. But is there no other solution or how else is it done normally? When filming in 24p there must always be a certain amount of motion blur inside. $\endgroup$ Commented Apr 17, 2021 at 15:47
  • $\begingroup$ We could probably figure out a better solution if you could provide some exemplary images to explain more precisely what you want to achieve along with the reasoning behind turning off motion blur for just one object. It's tricky to understand from a written explanation alone. $\endgroup$
    – HISEROD
    Commented Apr 17, 2021 at 16:02
  • $\begingroup$ Yes gladly. I have now inserted a picture of the boat scene into the question of where the camera goes to the boat. Since the boat does not move much during the tracking shot in the image section, it should actually be sharp there and only the water should have a motion blur effect. Blender still makes the ship very blurry. $\endgroup$ Commented Apr 17, 2021 at 17:11

1 Answer 1

0
$\begingroup$

Vector Blur Solution

When using the Vector pass and the Vector Blur node, individual objects can easily be "unblurred" by mixing in the raw render which has no blur.

To enable the Vector pass, Motion Blur must be disabled.
1

The Vector pass an be enabled in Properties > View Layer Properties > Passes > Vector.
enter image description here
I have also enabled Object Index for creating the object mask, but using Cryptomatte would work even better.

My boat proxy object has its Pass Index set to 1 for this mask.
3

In the compositor, the object's mask can now be used to zero the Vector pass and mix in the raw render where necessary as seen in the node setup below.
4
The Dilate/Erode node is used to reduce the color bleed artifacts from the Vector Blur node.

Side-By-Side

5
my proxy scene with the blur removed on the right side of the arrow object

$\endgroup$
5
  • $\begingroup$ Thanks for your answer HISEROD! I had heard of this solution before, but the problem with me is that I sometimes have very complex scenes like in the jungle with a large number of objects. Applying that to all objects differently for each movement would be pretty horror. I had thought that Blender could do this very easily with the Motion Blur Option by recognizing how much the object moves in the image section and blurs it accordingly.. $\endgroup$ Commented Apr 18, 2021 at 6:59
  • $\begingroup$ Will it be maybe useful to have a computer with RTX graphics cards for rendering?🤔 -> GPU-Accelerated Motion Blur in Blender $\endgroup$ Commented Apr 18, 2021 at 7:02
  • $\begingroup$ I believe that the accelerated motion blur is only for the Eevee and Cycles motion blur, not for the compositor effect. $\endgroup$
    – HISEROD
    Commented Apr 18, 2021 at 17:56
  • $\begingroup$ @Tim Cryptomatte should work really well for masking out many objects. $\endgroup$
    – HISEROD
    Commented Apr 18, 2021 at 18:38
  • $\begingroup$ Ok thanks again. I'll take a closer look at that in the next few days 🤔 $\endgroup$ Commented Apr 19, 2021 at 19:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .