1
$\begingroup$

When I do import my obj files it's become transparent in some part like in the picture

enter image description here I try to fix at here but all I can do is changing the subsurface color but I want the texture thing (I already have the texture but don't know how to put it in the transparent thing) enter image description here

$\endgroup$
4
  • $\begingroup$ You have used an alpha channel. Alpha is used to make part of a mesh transparent. That's why it's becoming transparent. $\endgroup$ Apr 17 at 10:17
  • $\begingroup$ how to fix that? $\endgroup$ Apr 17 at 10:48
  • $\begingroup$ Remove the Alpha Input to principled bsdf. If that doesn't solve it, please provide the blend file $\endgroup$ Apr 17 at 10:54
  • $\begingroup$ Since the hat is visible behind the hair, I don't think it is transparent because of the alpha - this looks like backface culling. If he changed the viewport shading to Solid or Rendered the transparency would be gone, it's only shown in the Material Preview. If the transparency is caused by the Alpha Channel it would be black in Material Preview (not transparent), unnoticable in Solid view and be transparent in Rendered view. Looking at the image, if the hat is supposed to have a texture that's not black, than it might be a combination of backface culling and alpha transparency. $\endgroup$ Apr 17 at 14:11
1
$\begingroup$

This looks like Backface Culling, i.e. when you see the backside of a face it is invisible. This helps for example if you want to see if some face normals are pointing in the wrong direction.

To disable Backface Culling, choose the material in the Material Tab and go to Viewport Display > Settings > Backface Culling and disable it (that's Cycles, in Eeevee it's in the overall Settings of the material).

But: if your material is invisible from the outside this presumably means that the normals on this object are turned inside out. In the Viewport Overlays you can enable "Face Orientation", the outside of faces are shwon in blue, the inside in red. I guess the faces of that object will show up in red.

To correct that go into Edit Mode, hit A to select all faces, then Shift+N to Recalculate Normals. You can tick Inside here if they are still red.

If only some faces are red and some are blue and recalculating normals doesn't make them uniformly red or blue, you can select the faces you want to change, hit Alt+N to bring up the Normals menu and choose "Flip".

EDIT: As I commented above, if the material has a texture which is supposedly not black, than you might have a combination of Backface Culling and Alpha Transparency.

Your screenshot shows that hat is transparent/invisible in front of the hair but all black behind the hair. Backface Culling and Alpha Transparency are shown differently in different Viewport Shading:

  1. In Solid view, you only see the faces without any transparency.
  2. In Material Preview, Backface culling makes faces transparent/invisible when seen from the backside/inside, while Alpha Transparency results in alpha values of 0 shown in black, not transparent. Alpha values > 0 have no effect and will make the material look opaque.
  3. In Rendered view, backface culling is disabled and doesn't effect the material, while Alpha Transparency will make the material more or less transparent according to the alpha value.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.