1
$\begingroup$

enter image description here

Situation:

  • I have two meshes with transparent materials.
  • Meshes share oneborder, however, they both have their own vertices, as they were created from a script.
  • All faces and all vertices on both meshes have the same positions.

Problem:

  • Faces of both meshes overlap each other in a weird, uneven way.
  • I understand that there might be a problem with vertex precision.
  • I cannot join both meshes as I need to animate them separately at some point.

Question:

Is there anyone out there who has a clue on how to get rid of this wierd overlapping of both materials? Is there anything that can be done with it node-wise or material-wise? I have dozens of those meshes. Moving each face a nanometer away from each other would take weeks.

$\endgroup$

1 Answer 1

0
$\begingroup$

You say that moving each face individually would take too long, but you can avoid that problem by moving them all at once:

  1. Select all your objects in Object Mode.

  2. Press Tab to enter Edit Mode and A to select all faces.

  3. Press AltS to perform shrink/fatten, which moves faces along their normals.

  4. Type a small, negative value like -0.01 and press Enter to confirm. (Depending on the details of your geometry, you may also want to try the Offset Even option in the operator panel, which could produce slightly nicer results.)

Now all your objects will be very slightly smaller, avoiding the overlapping faces.

$\endgroup$
1
  • $\begingroup$ Thank You. Sometimes a matter needs someone with a clear mind. $\endgroup$
    – pilotnik
    Apr 17, 2021 at 14:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .