5
$\begingroup$

Something happened this morning; I couldn't select (or deselect) any objects in the 3d editor viewport using left-click. I could do other things with left-click, e.g., move or rotate an object, just not select or deselect by clicking an object.

In user preferences/keymap/outliner I clicked restore; now I CAN select an object with a left-click on an object.

But NOW I can't select objects with a left-click-hold to "box-select" one or more objects, nor can I left-click-hold to box-select multiple vertices, etc., in Edit mode. My arrow cursor is set to Box Select.

I tried uninstalling and reinstalling blender. No change. I can't use left-click-hold to box-select multiple objects, vertices, etc. in the 3D Editor.
I also notice that NOW, when I select an object with a left-click, Blender has me in MOVE mode and the object moves if I move the mouse. This is also new.

I am able to use the hotkey "B" to bring up box select and draw a box, but I can't hold the left mouse button to draw a selection box.

Please help.

$\endgroup$
4
  • $\begingroup$ It sounds like perhaps you’ve accidentally switched to the “tweak” tool rather than the select tool. You could try pressing W, which is the default hotkey for the select tool, or you could pick it from the tools list. $\endgroup$ Apr 16, 2021 at 11:38
  • $\begingroup$ The cursor is set to box-select. I get nothing when I drag LMB. I can get a box with the B key. When I select an object with a direct LMB click the Move tool activates, even though it is not selected. $\endgroup$
    – G Lap
    Apr 16, 2021 at 12:30
  • $\begingroup$ Uninstalling won't help since Blender will still use preferences stored in the user config folder. You can delete those but you'll lose all changes you've made to Blender settings (same as loading factory settings and saving that). From your description keybindings for select and select+hold were changed in the prefs somehow. You restored select, now you need to find select+hold keybinding and restore / change it. It is not clear though how happens that Move tool is autoenabled, maybe a screenshot can help $\endgroup$
    – Mr Zak
    Apr 16, 2021 at 12:46
  • $\begingroup$ I have same problem. I tried disabling mouse button 4 (using x mouse button control) in case it was interfering somehow. Then click would work half of the time. Nothing else seems to work. $\endgroup$
    – Tirth
    Jun 17, 2021 at 5:16

5 Answers 5

3
$\begingroup$

Chose selection tool from the bar on the left. Go to Edit Mode. Right below the main bar (on the top) with File, Edit etc. there is a sign indicating which tool you are using at the moment. Next to this sign (on the right) there are five different selection modes, make sure you select the first mode (Set a New Selection), and you should be able to make selections again.

$\endgroup$
1
$\begingroup$

I recently had the same problem, somehow I messed my settings up.

Its because you messed up the key bindings. Open Blender (any file) and then go to Edit > Preferences menu, right next to File menu where you would go to save your work.

Go to the Keymap tab, and scroll through the option and find which one says Restore to the right of it. Click it and it should be fixed.

$\endgroup$
0
$\begingroup$

Try switching from Layout Mode to Modeling Mode, then back again. worked for me!

$\endgroup$
0
$\begingroup$

In my case I was in Cursor mode instead of Select mode.

$\endgroup$
0
$\begingroup$

I know this is old but I don't see it mentioned here and this is the first thing that comes up on google when you search this question.

In my case I'd somehow accidentally turned off "Show Overlays" (i.e. the orange outline when you select an object). This is the icon in the top right that looks like a venn diagram (hotkey Shift+Alt+Z) next to the wireframe/solid mode/shader mode/render mode spheres; make sure it's on.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .