0
$\begingroup$

I have no idea how to fix this. There is a yellow line that appears when i try to move the object. Don't know if that has something to do with it.

$\endgroup$
0
1
$\begingroup$

Does your object have animation keyframes? If so, blender won't 'let' you change it's location unless you have auto-keying turned on (the button with the little circle next to the 'play' buttons in the timeline panel), or if you manually insert a keyframe after moving, rotating or scaling your object.

As for the yellow line, it's probably because you have snapping turned on (the little magnet button on top of the viewport), but I don't think that has anything to do with what's preventing you from moving the object. Can you post a screenshot?

$\endgroup$
3
  • $\begingroup$ twitter.com/matsxio there is a video on my twitter page of this problem. I have no idea how to add a video to this place so twitter is the best i can do! lol $\endgroup$ – matsxio Apr 15 at 18:45
  • $\begingroup$ @matsxio you have a keyframe set in the timeline. Either delete the object's keyframes, or if you're trying to animate turn on the auto key-framing by pressing the button with the little circle on top of the timeline. To delete the keyframe right-click on the keyframe (that little yellow diamond shape in the timeline) and choose 'delete keyframes'. The yellow line has nothing to do with it, it appears because you have snapping turned on (the little magnet button on top of the viewport). $\endgroup$ – Alexandre Marcati Apr 15 at 19:05
  • 1
    $\begingroup$ THIS HELPED!!! THANK YOU $\endgroup$ – matsxio Apr 15 at 19:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.