2
$\begingroup$

I am trying to render the wire frame of (any) model using freestyle. I have followed every tutorial I could find, and no matter what settings I check or uncheck, the outline never renders.

I have tried Eevee and cycles and nothing happens. I have tried messing around with the node editor and if I render freestyle as it’s own pass, it’s just an empty layer no matter what I do.

This is my first time using blender (2.92) so it’s very possible I could be missing something, but I feel like all my settings match all the tutorials I’ve seen. I’ve only been trying to render on the default cube. What could I be missing?

$\endgroup$
7
  • $\begingroup$ Just one thing to eliminate first.. currently, Freestyle is not previewed. It appears only in renders through a camera... and it must be switched on in the Render settings. $\endgroup$
    – Robin Betts
    Apr 13, 2021 at 20:19
  • $\begingroup$ Yes! After messing around with it, I noticed you could not view freestyle in the viewport. But even by just enabling it and then trying to render the model (basic cube), no outlines appear. I have tried waiting to see if it shows up, but only the model renders. I’m stumped! $\endgroup$
    – Erin
    Apr 13, 2021 at 20:23
  • $\begingroup$ OK, next, set the lines crazy thick, and a crazy color. Set the Line Set to pick up 'Edge Marks', and mark all edges as Freestyle. Just to get rid of the easy things first. $\endgroup$
    – Robin Betts
    Apr 13, 2021 at 20:28
  • $\begingroup$ No luck there unfortunately. Set the thickness to 30 and color to a bright pink and no outlines rendered. $\endgroup$
    – Erin
    Apr 13, 2021 at 20:42
  • $\begingroup$ Hmm maybe share your file on pasteall.org/blend $\endgroup$
    – Robin Betts
    Apr 13, 2021 at 21:00

1 Answer 1

2
$\begingroup$

enter image description here

I figured it out! For some reason you cannot have "Freestyle SVG Exporter" and "Freestyle" both enabled in the render properties. By unchecking "freestyle SVG exporter", I finally could see an outline!

$\endgroup$
1
  • 1
    $\begingroup$ That's a weird one. Well done. Good to know. $\endgroup$
    – Robin Betts
    Apr 13, 2021 at 22:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .