0
$\begingroup$

I've been following this explosion tutorial. While I've managed to get a pretty great-looking explosion shape, it's just grayscale -- no color, even though I'm certain I've followed the shader edits very carefully.

screenshot of blender shader edits

I think the issue may have something to do with my GeForce GTX 470. I cannot get either cycles or eevee to render any of the smoke or explosion. I also cannot select any CUDA or OpenCL video card in preferences -> system. If I attempt to render with cycles using just the CPU, it renders the geometric objects (plane and ico sphere) but none of the particles, and none of the smoke or fire. Rendering with workbench will slowly build a very nice explosion of smoke but no color.

I have tried installing CUDA using several methods: nvidia, an older post about cuda 10.1, and just trying sudo apt install nvidia-cuda-toolkit.

The nvidia instructions and pretty much any other series of steps appears to install the nvidia-driver-460 which doesn't appear to be compatible with my system. Every time this driver is installed, my system reverts to 1024x768 on reboot and I'm unable to change this screen resolution nor am I able to use the 'additional drivers' control panel to select any other display driver. The control panel gets stuck on Continue using a manually installed driver, and all other options are greyed out. Furthermore, the nvidia-smi command complains that it cannot communicate with this driver. I've had to repeatedly remove this driver and revert to the current 390 driver which doesn't seem to expose the GPU for use by software:

$ nvidia-smi
Mon Apr 12 10:15:04 2021       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 390.141                Driver Version: 390.141                   |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 470     Off  | 00000000:02:00.0 N/A |                  N/A |
| 40%   58C    P0    N/A /  N/A |    506MiB /  1216MiB |     N/A      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0                    Not Supported                                       |
+-----------------------------------------------------------------------------+

Attempting to install the nvidia-cuda-toolkit using apt fails due to unmet dependencies. If you try and also install those dependencies, you end up with the 460 driver again which, as previously mentioned, is poorly behaved and confined to only 1024x768 display:

$ sudo apt install nvidia-cuda-toolkit
[sudo] password for sneakyimp: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-cuda-toolkit : Depends: nvidia-profiler (= 10.1.243-3) but it is not going to be installed
                       Depends: nvidia-cuda-dev (= 10.1.243-3) but it is not going to be installed
                       Recommends: nvidia-visual-profiler (= 10.1.243-3) but it is not going to be installed
                       Recommends: nsight-compute (= 10.1.243-3)
                       Recommends: nsight-systems (= 10.1.243-3)
E: Unable to correct problems, you have held broken packages.

Can anyone tell me how to get Blender to apply these colors to my explosion using Workbench to render? Even better would be if someone can help me get blender to utilize my GPU? The tutorial showed the smoke colors changing as the person worked, my shader edits don't seem to have any impact on the appearance of the smoke as I work. I've also downloaded and tried the very latest blender 2.92 but the smoke is just black and you can't see any detail at all.

$\endgroup$
4
  • $\begingroup$ I see you have Viewport Shading mode set to: Solid. Change it to Material Preview mode. docs.blender.org/manual/en/2.91/editors/3dview/display/… $\endgroup$ – james_t Apr 12 at 18:41
  • $\begingroup$ Search the web: I found this about the GeForce GTX 470 blenderartists.org/t/gtx-470/546471/3. are you on a MAC or Win-10 or?? $\endgroup$ – james_t Apr 12 at 18:46
  • $\begingroup$ also: code.blender.org/2019/04/supported-gpus-in-blender-2-80 ... If you cannot get the GeForce GTX 470 to be recognized with your blender edition, you could try using a rendering farm. There is a (sort of) free farm called SheepIt at sheepit-renderfarm.com/index.php . Download the client and start it up as they won't let you rend much if you don't also allow your computer to volunteer render for others (at least while you have an active rendering submission) $\endgroup$ – james_t Apr 12 at 18:53
  • $\begingroup$ @james_t as I indicated in the title of my post, I'm running Ubuntu 20.04. I've been battling this and searching for solutions for 2 days now and have tried half a dozen different ways to install CUDA, which is apparently what is required (?) and every variation installs the nvidia-driver-460 which only displays at a miserable 1024x768. Thanks for the tip on material preview, though. I'm currently shopping for video cards. $\endgroup$ – S. Imp Apr 12 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.