2
$\begingroup$

I have used a cube and applied a principled volume/volume scatter on it. When I render an animation in Eevee with a still camera it renders just fine. But when I apply keyframes to the camera with a simple location movement, the volume fog starts moving.

Here's the GIF Preview of the render

enter image description here

My project settings are as follows: Render Engine Eevee - Sampling Render 128 - Viewport denoising on - Ambient Occlusion off - Bloom off - Frame rate 25 - Res 1920 x 890 Blender 2.92

Cube enter image description here

Setup enter image description here

Can anyone help what might be causing this?

Thank you

$\endgroup$
2
  • $\begingroup$ can you provide blend file? $\endgroup$
    – Chris
    Apr 12 at 11:18
  • $\begingroup$ Thanks Chris, just emailed you the blend file. $\endgroup$ Apr 13 at 6:26
1
$\begingroup$

In Eevee, volumetrics are approximated by combining a number of 'slices' of the volume together. While being much more efficient than rendering the complete volume, the accuracy is very dependent on the number of 'slices' used and how those are spread through the view.

You are seeing artifacts resulting from those 'slices' being in a different position for each subsequent frame and while this wouldn't be noticeable in a still image, it becomes very apparant in the animation.

The solution to this is to increase the number of 'slices' present so that any gaps between them are smaller and therefore far less noticeable. There are a number of ways of achieving this :

  1. Increase the number of Samples in your rendering (the 'Render' and 'Viewport' settings in the Sampling section of the render properties). More samples will result in more detail being rendered in your volume. More samples will slow down your rendering - but should also produce better results.
  2. Increase the number of Samples in the 'Volumetrics' section of the render properties. Again, more samples will take longer to render but will improve the quality of the volumetrics.
  3. Concentrate the volumetric samples in a smaller part of your scene by changing the Start and End settings in the Volumetrics section of the render properties. The 'Slices' of your volume are only calculated for a distance from Start to End from the point of view (the camera or the viewport). If you have 'Start' set very small and your volume is a fair distance from the camera then there is wasted space that will waste your samples on slices that do not have an volume of interest. Increase 'Start' to the distance where your volume starts. Similarly, if 'End' is way beyond where your volume finishes then it will waste 'slices' that will never contain volume. The default values are 0.1m and 100m respectively. If your volume starts at 20m from the camera and ends at 60m from the camera then changing Start and End to 20 and 60 will concentrate the volumetric samples over just that range.

By making the above changes the volume 'slices' will be more concentrated in your area of interest and you should have far less noticeable artifacts.

$\endgroup$
1
  • 1
    $\begingroup$ Thank you Rich Sedman, increasing the samples helped solve this issue. Thank you very much $\endgroup$ Apr 14 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.