I'm trying to animate a figure to jump and the animation runs fine when I play it in timeline but when I render image/animation, it also shows the initial T-pose figure that I started with: in render image what i found is that in the edit mode the shape of the figure is still in the initial t-pose and the armature seems disconnected from the object

in edit mode:  in edit mode whereas in the object mode the armature and body are connected and not in t-pose

in object mode:  in object mode

is it because I had not applied the armature modifier before making the animation?

  • 1
    $\begingroup$ When you hop into Edit mode then the mesh is automatically put in rest position. That's the reason why it looks different in Object mode (pose position) and Edit mode (=rest position). You can switch the position in the Object Data Properties of the armature ("green running man" icon) $\endgroup$
    – Blunder
    Commented Apr 12, 2021 at 14:10

1 Answer 1


It is because you have a duplicate of your object in you scene. The one named tpose_human_body. I see you have it hidden but blender still renders it. If you want it to not be rendered move it into a new collection and disable the collection from the view layer by unchecking the tickbox near it.

There was a simpler way to disable render for objects before but it has changed and I don't know how to do it in 2.8.


In 2.7's Outliner, after each Object's name there was the Restriction Toggles button :

enter image description here

The right most button (the one that looks like a camera) is the one used for disabling/enabling an object for render.

In 2.8+, one might think that those buttons were gone but they are just hidden. In the Outliner's header, there is a Filter dropdown :

enter image description here

If you click on this you will see a section called Restriction Toggles :

enter image description here

You'll find the one that you're looking for there : enter image description here

If you enable it, you should see it in the Outliner now :

enter image description here

Clicking on it will toggle between visible and invisible in renders.

  • $\begingroup$ Your suspicion is correct there was an extra object in my collection that I had hidden which was standing in t-pose though it is not the tpose_human_body object which is another plane as image that I imported which also shows in the render if in the camera's area even when hidden. thanks! $\endgroup$
    – Manik
    Commented Apr 12, 2021 at 17:58
  • $\begingroup$ You're welcome. I'm glad I helped. $\endgroup$ Commented Apr 13, 2021 at 11:51

Not the answer you're looking for? Browse other questions tagged .