0
$\begingroup$

I have a scene that is a plane from the Images as planes addon bent into a circle, and factor is acting strange in it. enter image description here

As you can see from the picture, white is above blue, but in the node network there is no white. On top of that, the gradient texture shows that white is above black, meaning that blue should be on top. Im not sure if this is related, but on top of that the invert node turns everything white. I know that the images as planes addon acts weird with materials, but Why is this happening?

Blend file -

$\endgroup$
7
  • 1
    $\begingroup$ You know, you could simply try turning the mesh upside down using rotation. It should probably look correct, why it is happening? I have no idea but is probably a bug. $\endgroup$ Apr 11, 2021 at 3:42
  • $\begingroup$ That isn't the only problem. The white should not be there, it should be yellow on the bottom and blue on top, as the node network shows. Anyway, this is just a simple demonstration of the problem. My actual node network is much more complex, so I need the long solution. $\endgroup$
    – Relevred
    Apr 11, 2021 at 4:29
  • 4
    $\begingroup$ Then can you show the complete node setup? $\endgroup$ Apr 11, 2021 at 4:46
  • 1
    $\begingroup$ Use a color ramp instead. $\endgroup$
    – brockmann
    Apr 11, 2021 at 11:20
  • 2
    $\begingroup$ No shortcut... also there is nothing wrong. It's just your "wrong" expectations: i.sstatic.net/Bao6Y.jpg $\endgroup$
    – brockmann
    Apr 11, 2021 at 13:37

0

You must log in to answer this question.

Browse other questions tagged .