2.92 version. New file. Object in viewport.

Material Properties!Surface!Roughness = 0

Material Properties!Surface!Transmission = 1

Material Properties!Settings!Screen Space Refraction: ticked

Render Properties!Screen Space Reflections: ticked

Render Properties!Screen Space Reflections!Refraction: ticked

Object appears in Eevee Material Preview with viewport's dark void background with a Blender-default garden picture file that fills the object, and in 6 DOF the garden imagery fills all of it.

Now I drop a sky dome over it, and then orbit:

enter image description here

Where the sky dome appears behind the refracting object, the Blender-default garden file imagery disappears,...but then reappears, resolving into some kind of cube of its own in the refraction. (The coral colored box is a separate entity.)

The garden file imagery is here, in a shader/texture provided as a default by Blender:

enter image description here

How can that garden image be turned off inside the refracting object (at the very least when the sky dome appears in the background behind the refracting object)?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.