1
$\begingroup$

there are 3 planes, each plane has two particle hair systems. the particle hairs that on the same plane has the same material. in blender 2.83 LTS. the color display as intended. since 2.90, the particle hair looks different. when both hair system are active, the color is mix with other hair particle color of different planes, if disable either one of the hair system that on the same plane, the color return to normal.

as you can see in the picture below, I set the material to mix of primary color red green and blue with secondary grey color. in 2.83 it looks right, but in 2.90 and above, the blue and green materials also mix with red somehow.

here is a link to the blend file: https://drive.google.com/file/d/1Ai8InP7sNN0hHDHC-sD8gvr5ZL9BCEz9/view?usp=sharing

enter image description here

enter image description here

$\endgroup$
-1
$\begingroup$

I have no idea why you need two particle settings on each plane but if you don't need it really. If you delete the second particle system on each plane, it works.

$\endgroup$
2
  • $\begingroup$ yes it works if only one particleSystem is active, but when it works in 2.83, not post 2.90. I wonder if it is a bug and should be reported. $\endgroup$ – sleepyhead Apr 9 at 0:54
  • $\begingroup$ I think it is a bug. $\endgroup$ – Chris Apr 9 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.