0
$\begingroup$

Blend file.

Video Explanation.

I made a collection with an object parented to a bone. The bone has a property in pose mode and drives a color change in the material of the object. When I link this collection to another blend file and save the property stops working. How can I correct this? I need to be able to do this w/o changing the material and adding a driver to it every time I open the file.

$\endgroup$
1
$\begingroup$

When you go to Outliner, right click over Material item and choose Resync Library Override it brings driver to work, but after reopening file it is not working again and I had to Resync again.

From video it looks like you are using 2.92 in this version when saved&reopen (or your Revert), Material became Linked (chain icon) for some reason, that is why driver is not working. It is the same issue like I noted in your previous Q with Action. You have to right click on Material item and manually Add Library Override first (so it became chain with arrow icon). Than Resync LO.

enter image description here

In 2.93 your driver is not working from beginning, even in this version Material has LO icon it is not working anyway and Resync LO is needed as well.

Note: I have zero experiences with LO as mentioned, but it seems to me like a bug or not working feature since LO is very new to blender, so it can be just a corner case yet in development. Try to post it as a bug and mention bug report link here in a comment, so others can follow developers statement of this thing. Thank you


In latest experimental build 2.93 I noticed under User Preferences > Experimental ... there is Override Auto Resync with a link to https://developer.blender.org/T83811 so you can get more info. But seems like not covering your issue yet (from what I tried - still manually).

If someone smarter here can explain more.

$\endgroup$
2
  • $\begingroup$ Thank you. I'll take you advice and post it as a bug. $\endgroup$
    – jitone1
    Apr 11 at 3:57
  • $\begingroup$ Even the link to devs is closed they usually react for a new reasonable comments there, so ... I would suggest to write your issue with driver there and see what they think about it before you post a bug ... probably it is a missing feature than a bug. Like here when I searched for "Library Override Drivers" here is one of them developer.blender.org/T70319 ... marked as "TO DO". $\endgroup$
    – vklidu
    Apr 11 at 9:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.