When I do a box select on an object in edit mode where I only want to select the visible edges, after selecting and zooming in, I see it hasn't selected a bunch of small edges. How can this be? I cannot zoom into my model and then constantly check every short edge if it's selected or not, that would hinder my design process too much. This happens in both vertex select mode as well as in edge select mode.

When I zoom in, I can still select these edges no problem. Using Blender 2.92.0

Is there a way or plugin to 'select visible edges' or 'select visible vertexes' or some other option? Right now I have to do a merge by distance, but it sometimes turns my artwork too low poly.

Example: enter image description here


1 Answer 1


This is because when zoomed out, floating point errors cause incorrect detection of what edges are visually obstructed by other geometry when the edges are small compared to their size on screen.

You can get around this by going into a view mode where visually obstructed geometry may be selected. Either x-ray or wireframe mode will do this. It's unfortunately not a prefect solution but I find it works fine most of the time.

  • $\begingroup$ Thanks, I indeed expected this was the issue as well. The problem is that I intend to obscure the backside edges so that's why X-ray is turned off as to force the selection to be only what I can see... I was already in wireframe mode with x-ray turned off. I guess there's no way to tell Blender to 'select visible' or something. Maybe an interesting one for a future addon, not by me (I'm not good enough at that). $\endgroup$
    – Marinus
    Commented Apr 7, 2021 at 19:22
  • $\begingroup$ @Marinus Well the problem is that the default behavior is "select visible", it's just not possible to entirely determine what is visible when things are really tiny due to floating point inaccuracies and things just being too tiny to get any pixels on screen. $\endgroup$
    – PGmath
    Commented Apr 7, 2021 at 19:35
  • $\begingroup$ @Marinus This site is not a regular forum, please don't reply "Thanks" as an answer or comment, instead upvote the post that helped you. If you feel it completely solved your issue consider marking it as accepted. $\endgroup$ Commented Apr 7, 2021 at 20:50
  • 1
    $\begingroup$ @Marinus We understand that you want to be polite. But Duarte is simply explaining to you how this site works. When you post something as an answer which is not an answer, this potentially has more consequences than merely ruffling a few feathers. It can have real consequences, since it has the potential to confuse both users and search results. If it's a practice that becomes widespread, then the effects become more problematic, and the site is in danger of becoming useless. To avoid that fate, we rely on dedicated users to inform newcomers about how this site works. $\endgroup$
    – R-800
    Commented Apr 8, 2021 at 7:24
  • 1
    $\begingroup$ @MarkusvonBroady well I guess in a way it's a bug, but if my understanding of what's going on is correct, fixing it would mean changing the entire way Blender calculates what geometry you're clicking on. When you zoom out so far that some geometry isn't represented by any pixels on your screen, Blender assumes that geometry is obscured and doesn't select it. $\endgroup$
    – PGmath
    Commented Apr 8, 2021 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .