1
$\begingroup$

I can not bake my character's materials to a single texture for export into Unity.

When I have the "selected to active" I get an error message "no valid objects". See bottom right. enter image description here

When I remove "Selected to Active", I can bake the image however the texture ends up looking like this. enter image description here

So thinking this is a UV unwrap error, and using the tutorials from others. I created a new UV unwrap image. Did a smart unwrap and I get a perfect unwrap, but no baked textured image :-(....

enter image description here

So I short 3 tutorials later, I can't bake multiple textures from a single object onto a single textured image. I realise I must be doing something wrong ...

$\endgroup$
3
  • $\begingroup$ In each material you have to have selected the same Texture node with image you want to all bake happen. Selected to Active is a feature that let you bake from one object to another. $\endgroup$
    – vklidu
    Apr 4, 2021 at 18:13
  • $\begingroup$ I'm not following? I've tried baking in UV didn't work in Shader tab that didn't work either.. I'm obviously missing something fundamental? Thanks in advance $\endgroup$
    – CromeX
    Apr 4, 2021 at 18:16
  • $\begingroup$ Your character contains several materials, Go to Shader editor and for each material place unconnected Texture node as shown already in your screen. It just has to be done for every material node tree. If it is not clear I will create an answer, but here on site has to be an answer already ... $\endgroup$
    – vklidu
    Apr 4, 2021 at 18:19

2 Answers 2

5
$\begingroup$

Cube has attached three separate Shaders (materials) - Pink, Green, White ...

enter image description here

To bake them into one texture ... add Texture node with new (empty) image and keep node selected. Do the same for other materials (like here for Pink and White). Just copy&paste node and keep selected.

enter image description here

In case you want bake only color pass, select Diffuse and uncheck Direct and Indirect Light.

enter image description here

$\endgroup$
1
  • $\begingroup$ Thanks Mate, appreciate your answer. $\endgroup$
    – CromeX
    Apr 5, 2021 at 11:14
0
$\begingroup$

Ok I found out my problem, FYI for those behind me.

In the shader menu, A new "Image texture" is required for every material, set that new image material to the UV wrap material in the UV editor..

Here is the video that helped me. Thanks One studio

enter link description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged .