0
$\begingroup$

I have enabled smooth shading with and without auto smoothing, played with the normals, and tried a million other fixes but i after many hours of trying have made no process, i also searched online and didn't find any fixes to this issue

how can i fix this? any help is much appreciated! :)

link for file here!

weird triangle

enter image description here

$\endgroup$
5
  • 1
    $\begingroup$ Wireframe please? $\endgroup$
    – Bruk
    Apr 3, 2021 at 21:07
  • $\begingroup$ added the wireframe picture now $\endgroup$
    – TiigerPro
    Apr 3, 2021 at 21:40
  • $\begingroup$ That’s not a full wireframe, go out of edit mode and enable wireframe under shading options. $\endgroup$
    – Bruk
    Apr 3, 2021 at 21:42
  • $\begingroup$ I uploaded the file here so download it and view it, if you figure out a fix, lemme know :D thanks! tempdrive.io/us/xnfuyhx0 $\endgroup$
    – TiigerPro
    Apr 3, 2021 at 22:04
  • $\begingroup$ Ngon is the reason, I believe, the one between inner and outer border edges. If you cut edges at least until it's convex and not a curvy one it would become better $\endgroup$
    – Mr Zak
    Apr 3, 2021 at 23:23

1 Answer 1

2
$\begingroup$

This is happening because of the ngons. If you look your model from side, you'll notice the face is not actually flat. side view of diagonal face

There are two ways to fix them.

First(quick and dirty): use Weighted normal modifier with Keep Sharp option enabled. Weighted normal applied

The shading is better now. However, the topology issue stays still since the Weighted normal modifier changes normals only.

Second(better way to handle this issue): Recreate the model and use Weighted normal modifier on it. There are unnecessary bevels(like the "triangle-shaped" bevels that will create the shading issues on your model. Moreover, they will create unnecessary vertices.

If you want diagonal face with bevels, the topology should look like this: better topology

And because this topology still makes ngon on the top(which will make shading issue too), use Weighted normal modifier to fix the shading issue.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .