0
$\begingroup$

I set a bone to copy rotation of the arm bone when it rotates on Z axis to enable a corrective shape key. The problem is that when i rotate the arm on the X axis, the bone that is copying rotation rotates on Z axis and enables the corrective shape key, distorting the mesh.

enter image description here

$\endgroup$
3
  • $\begingroup$ if you rotate Arm1.L on the global X axis, it will make it rotate a bit on its local Z axis a bit, as this bone is not completely align on the global axis. Is it your problem here? $\endgroup$
    – moonboots
    Commented Apr 2, 2021 at 20:01
  • $\begingroup$ Yes, the bone shouldn't rotate on Z axis when I rotate it on X axis. $\endgroup$
    – Paul
    Commented Apr 2, 2021 at 20:16
  • $\begingroup$ well, as I say, it does, as it is not completely aligned with the global X axis, rotating the bone on the global X axis makes it rotate on its local Z, if you align it completely with the global X axis, it won't happen any more $\endgroup$
    – moonboots
    Commented Apr 2, 2021 at 20:18

1 Answer 1

1
$\begingroup$

as your bone is not completely aligned with the global X axis, rotating it on the global X axis makes it rotate on its local Z. If you align it completely with the global X axis in Edit mode, it won't happen any more. Once aligned:

enter image description here

Not sure why you need to rotate it on the global X axis though, just keyframe rotations on its local Y axis.

$\endgroup$
2
  • $\begingroup$ I don't know how to align the bones, is it putting them straight in line? because it didn't worked, tried going to armature and clear rolls and other options there, but it doesn't work either. $\endgroup$
    – Paul
    Commented Apr 2, 2021 at 20:37
  • 1
    $\begingroup$ S Z 0, S Y 0, and Shift N > Global + X Axis $\endgroup$
    – moonboots
    Commented Apr 2, 2021 at 20:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .