1
$\begingroup$

I've been following a tutorial on geometry nodes, which uses gumdrops and sugar for context. The geometry node set up for the gum drop is:

geometry node

For the material of the gum drop I used the following shader set up:

Shader Set up

The problem I have is on the render. If you look at the image below, You'll be able to see little shadows appearing inside of the gumdrop material. I want to be able to control these, either removing them completely or reducing the strength of them.

Gumdrops with shadows

I've tried a few different things to alter them, but I've not been able to work out what is causing them.

I've tried removing Shadows in the Ray Visibility section, from the sugar cube objects, used within a collection in the geometry node setup. Specifically the collection is used in Point Instance Node.

Shadows off

I've tried increasing the Density in the Volume Absorption node in the gumdrop material Shader Node Setup, but it just darkens the colour, so the shadows blend in, and I would like to keep the brightness of the gumdrops if possible.

The last idea I had was to apply 'backface culling', but the option only appears in the Viewport Display settings, so doesn't affect the render. (I figured maybe the shadows are caused by sugar on the back of the gum drop.)

I'm not sure what's causing the shadows, and I've only been using 3D modelling software about 2 months, so I have no idea what else to try.

Any ideas or solutions?

$\endgroup$
1
$\begingroup$

Moments after writing up this question, I found an answer. The way to do it is to alter the Roughness value in the Refraction BSDF node of the shader set up.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.