All of a sudden, in a particular scene I am working on, the edges of all the models have become partially transparent. It is like what happens when you have a very small start clipping pane and are looking at a small model up close. Except the clipping panes have not been changed, most of the objects in the scene are not very small, and I am not zoomed way in.

Here is a screenshot:
enter image description here

The crude barn thing pictured in the screenshot is about 30'x25'x26' and the zoom is pretty standard. This behavior is also not dependent on the zoom, and again, I have not changed the clipping panes.

And I do have limit selection to visible checked, it does look similar to what it would if that was disabled, but that is not the problem.

What is this caused by and technically what is responsible for it?

  • 1
    $\begingroup$ Do you have any modifiers on your object? $\endgroup$ – A Wild RolandiXor Jan 4 '15 at 21:27
  • $\begingroup$ @RolandiXor Some objects have modifiers, but not all (the pictured one has none). But the problem affects the entire scene. $\endgroup$ – PGmath Jan 5 '15 at 1:39
  • $\begingroup$ Would you mind uploading the file? You can try here then paste the download link to the question. It would be strange if cegaton's answer isn't the right one. $\endgroup$ – Leon Cheung Jan 5 '15 at 3:23
  • $\begingroup$ That question is NOT a duplicate. As I said in the question, I know it has to do with clipping panes! I am asking why it is happening on large objects regardless of zoom and throughout the entire scene, even though the clipping panes have not been changed. The file is much too large to upload to pastall.org, but I will try to create a copy and delete most of the objects to shrink the size. $\endgroup$ – PGmath Jan 5 '15 at 15:03

What you are seeing is directly related with the value on the clip start distance.

enter image description here

Bring up the value a bit and the effect will go away.

enter image description here

Seems like setting the start clip distance to anything smaller than 0.1 (or 10cm if using metric) will bring that weird transparency.

|improve this answer|||||
  • 2
    $\begingroup$ But this has never happened on any other of my scenes and as I said in the question, I have not played with the clipping panes. Also, what is this phenomenon and what technically causes it? It has always kind of bugged me when I am modeling small things. $\endgroup$ – PGmath Jan 5 '15 at 2:30
  • 2
    $\begingroup$ So you're saying this answer didn't help? $\endgroup$ – A Wild RolandiXor Jan 6 '15 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.