0
$\begingroup$

I have video with transparent background which I wanna import to Blender sequencer. I've checked in my browser that my video is 100% has transparent background. When I add it to sequencer in blender it has black background. When I export it using WebM I also get black background on time when transparent video should be placed but transparent where I place some transparent pngs. So transparency is active but seems blender can't import transparent videos.

This video imports to Davinci Resolve without any problem.

What do you think?

Blender 2.93.0a
My video's format: WebM, libvpx-vp9.
Ubuntu Linux.
$\endgroup$
3
  • $\begingroup$ I would say you will have to convert webm to PNG sequence. There exists a bunch of free online convertors or if you have FFMPEG installed use command ffmpeg -vcodec libvpx -i yourvideo.webm frames/%04d.png ... Sure change "yourvideo" to name of your file. $\endgroup$ – vklidu Mar 27 at 9:30
  • $\begingroup$ Did you switch the compositing in the strip sidebar to alpha over? $\endgroup$ – tintwotin Mar 27 at 16:05
  • $\begingroup$ @tintwotin, yes. Finally I found there's some transparent format that Blender supports for transparency, it's: -vcodec prores_ks -pix_fmt yuva444p10le -profile:v 4444 $\endgroup$ – JavaRunner Mar 27 at 16:24
0
$\begingroup$

Solved.

However I found some transparent format that Blender supports for transparency, it should be reencoded like this:

ffmpeg -i in.webm -vcodec prores_ks -pix_fmt yuva444p10le -profile:v 4444 out.mov

"Blend"-option should be set to "Alpha Over" in the N-panel of the strip.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.