3
$\begingroup$

How do I extrude a face loop selection along face normals?

To grasp the problem, take a convex shape such as the back of a satellite dish. If you would like to see in what direction that I would like this face loop to extrude then turn on Face Normals (Properties Panel>Mesh Display>Normals>Display Face Normals as Lines)

If I individually select each face and extrude it with the same value I can get the effect that I desire, but it then requires cleanup to delete all extraneous faces on the ends of each extrusion and then the vertices must all be selectively merged at center. This takes an unbelievable amount of time to do. I have not been able to find any combination of Transform Orientation or Extrusion settings (or using Alt+S) that will extrude a face loop in the direction of the individual face normals.

What options if any will perform this operation more quickly than what I am doing?

Convex shape with a loop of faces to be extruded

Desired extrusion - a face loop extruded along face normals

Extruding each and every face along their respective face normals

Deleting extraneous face on the ends of each and every extrusion

Merging specific sets of vertices at center

Extrude with Region Vertex Normals

$\endgroup$
  • $\begingroup$ Possible duplicate of blender.stackexchange.com/questions/7365/… $\endgroup$ – iKlsR Jan 3 '15 at 21:12
  • $\begingroup$ I searched that question prior to asking this question. I couldn't find anything that helped me extrude along "face" normals, but if I missed the solution then please enlighten me. $\endgroup$ – Bryson Jack Jan 3 '15 at 21:14
  • $\begingroup$ Check under Local Orientation. $\endgroup$ – iKlsR Jan 3 '15 at 21:16
  • $\begingroup$ Ahh, now I understand. I went back to the question that you linked to and followed the steps under Local Orientation. If you look at my picture that says "Extrude>Region Vertex Normals Results", you will see exactly what it looks like once I follow your method. I have no idea what has made it so that Blender is behaving differently than expected, sorry. That result is what it looks like when I tried Local and Normal. $\endgroup$ – Bryson Jack Jan 3 '15 at 23:31
5
$\begingroup$

The normals on your object are not correct because the object is rotated 90 degrees in object mode. To fix select your object, press CtrlA and Apply Rotation and Scale. Then your normals will work for the extrusion operation you want to do.

enter image description here

enter image description here

read: http://wiki.blender.org/index.php/User:Fade/Doc:2.6/Manual/3D_interaction/Transform_Control/Reset_Object_Transformations and http://blenderartists.org/forum/archive/index.php/t-106188.html

$\endgroup$
  • $\begingroup$ Thanks for the solution and the reference links. I appreciate it. $\endgroup$ – Bryson Jack Jan 3 '15 at 23:48
4
$\begingroup$

You can try using the inset tool I using Outset

enter image description here

$\endgroup$
  • $\begingroup$ If you look at my picture that says "Extrude>Region Vertex Normals Results", you will see exactly what it looks like once I follow your method. I have no idea what has made it so that Blender is behaving differently than expected, sorry. $\endgroup$ – Bryson Jack Jan 3 '15 at 22:39
  • $\begingroup$ I can think of two things you can check: 1 turn off proportional editing and 2 make sure your pivot point is set to median point and not 3D cursor. i.stack.imgur.com/ckl9B.gif $\endgroup$ – cegaton Jan 3 '15 at 22:44
  • $\begingroup$ Proportional Editing is off and my pivot is set to Median. Here is my blend file if you want to check it out. dl.dropboxusercontent.com/u/6647893/Forum_Help/… $\endgroup$ – Bryson Jack Jan 3 '15 at 22:54
  • $\begingroup$ @BrysonJack In object mode press ctrl A "apply rotation and size" then your normals will work fine. $\endgroup$ – cegaton Jan 3 '15 at 23:20
  • $\begingroup$ Yep. That was the fix. Thanks so much for your help. All of you. $\endgroup$ – Bryson Jack Jan 3 '15 at 23:33
2
$\begingroup$

You can extrude along Vertex normals; vertex normals and face normals are *always* the same (they're not if you use seams).

To do this, first select the region you want to extrude, then open the Toolshelf (press T); In the Tools tab, under Mesh Tools press the Extrude button - it will show you a list of possible extrusion methods - and choose Region (Vertex Normals) (shortcut V, while in that menu).

enter image description here

$\endgroup$
  • $\begingroup$ Yeah, I definitely tried Region (Vertex Normals) before posting. I don't get the desired output. $\endgroup$ – Bryson Jack Jan 3 '15 at 22:07
  • $\begingroup$ @BrysonJack Have you tried extruding, cancelling the transform and then scaling with normal orientation? $\endgroup$ – someonewithpc Jan 3 '15 at 22:11
  • $\begingroup$ Yeah, I just tried that and it does the same thing as just extruding with Region (Vertex Normals). Is canceling the transform and scaling with normal orientation supposed to do something different? $\endgroup$ – Bryson Jack Jan 3 '15 at 22:13
  • $\begingroup$ It then scales along face normals which seemed to be what you wanted; can you edit your question to better explain what you want? $\endgroup$ – someonewithpc Jan 3 '15 at 22:16
  • $\begingroup$ Honestly I can't, and I even took the time to elaborate with pictures, which are supposed to be worth a thousand words :) If you are able to reproduce my desired result with a similar convex shape, I would love to know how you do it. $\endgroup$ – Bryson Jack Jan 3 '15 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.