1
$\begingroup$

I am trying to apply a UV image with no tiling in Cycles. I have tried using the Texture Coordinate with a Mapping node as suggest in other examples. I have also tried using the Attribute node (I couldn't get that to work at all).

So far using the Texture Coordinate with Mapping nodes does stop the tiling, but it leaves these strange stretched portion of the image going over the rest of the mesh.

Is there a way that I can stop those extra stripes from appearing?

Example attached Rendered example

I have attached the node setup below Node setup

Thanks

$\endgroup$
3
$\begingroup$

Cylces does have the bad habit of stretching the pixels past the edges of the image.

enter image description here

One quick solution is editing your image and adding a black or transparent border all around. (All you need is one pixel wide ...). enter image description here

Cycles will then repeat that border...

Or you can create a file that is a black border around a transparent image and use that as a factor on a mix node to create a color frame past your image:

enter image description here

or a different shader:

enter image description here

$\endgroup$
0
$\begingroup$

For many situations I have found that setting mapping node min and max values to -.001 and 1.001 respectively has produced good results, eliminating the stretched edges.

enter image description here

Without this I get a result like...

enter image description here

With the min and max hack in place I get a result like...

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.