I want to paint a texture on an object using another object as a mask. The object to paint has a complex shape, and I want to define the mask using a 3D object and a boolean intersection/difference, so I add the boolean modifier to my paintable object - everything works fine. However, when I switch to Texture Paint mode, the boolean modifier is ignored, and I get to paint on the whole surface of the object.

Basically I'm trying to do what I saw in this video: I know it refers to an older version of Blender (2.7x), but I wonder if it's still possible to do this in 2.83 and higher.


I tried starting from scratch, and the modifier is applied as it should. It seems that the issue has something to do with the object I'm using, but I can share that as is because it is a derived work from a file I don't have the rights to (I'm creating an original skin for a car from a game; the model itself won't be part of my end result).

I'm trying to isolate what particular details of that model cause the misbehaviour, but I still haven't succeeded. For now, another object created from scratch, that has a boolean modifier on it, appears bool-cut in Texture Paint mode and in Object mode (of course not in Edit mode); if I Texture Pain the new object, the car model (that is in Object mode) appears bool-cut; as soon as I switch to Texture Paint with the car as the active object, it appears non cut.

  • $\begingroup$ it seems to work fine with 2.9, maybe show some screenshots or even share your file? $\endgroup$
    – moonboots
    Commented Mar 26, 2021 at 11:48
  • 1
    $\begingroup$ Should still work - have you tried using a simple cube to try the scenario out and identify the breakdown in results versus method? $\endgroup$ Commented Mar 26, 2021 at 12:15
  • 1
    $\begingroup$ In fact I just tried with a new file, a cube intersecting another cube, and it worked. I'll try to isolate the issue and replicate it with the simplest file possible. $\endgroup$
    – Simone
    Commented Mar 26, 2021 at 14:48

1 Answer 1


I found the solution. There's a button that enables the Paint Mask mode, which caused the behaviour I was experiencing.

If the button is OFF (as in the picture), the whole mesh (after applying modifiers) can be painted on.

If the button is ON, then face selection masking is enabled, and the selected faces of the mesh (without applying modifiers) can be painted on.

Paint mask button


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .