0
$\begingroup$

Im making a guitar slanted guitar cabinet. Im having some weird bevel issues shown below.

enter image description here

The corners have a weird shading issue. This is whats happening at the corners: enter image description here

I can kind of fix it by unchecking "loop slide" in the bevel operator, and i get this result: enter image description here

It fixes most of the problem, but there is still a corner with weird shading.

My normals are all blue, no extra verts and scale is 1.000. No clue whats going on.

I added a basic cube and added an edge loop in the middle, then pulled one side back and still got the same thing:

enter image description here

Any ideas why this is happening? Thanks!

EDIT: i turned the bevel shape to 0.900 and the 2 effected corners are exaggerated. Why are just those 2 corners not beveling right?

enter image description here

I have recalculated the normals too and they are fine. I have started from scratch and then i get different results as to which corners have the "bad" shading

$\endgroup$
5
  • $\begingroup$ hello maybe share your original object? pasteall.org/blend ... have your shade smooth your object? are there edges overlapping? $\endgroup$ – moonboots Mar 26 at 6:59
  • $\begingroup$ Hello :). I can confirm this issue - the shading gets progresively weirder with increasing number of segments. $\endgroup$ – Jachym Michal Mar 26 at 16:59
  • $\begingroup$ Here is the blend: pasteall.org/blend/e88b3bc458894adc863a3bf14b103ad8 $\endgroup$ – Rikky Richardsonn Mar 26 at 17:21
  • 1
    $\begingroup$ Maybe like this. Side horizontal loops optional, just there for all quads, subdiv workflow. $\endgroup$ – Robin Betts Mar 26 at 20:06
  • $\begingroup$ Thanks @RobinBetts. I never think to use subdiv for these kinds of things. Usually the bevel works fine. I will give this workflow a shot, thanks! Also i got a better result using a boolen for the angle cut. I only had the back, bottom right corner with the shading artifact. $\endgroup$ – Rikky Richardsonn Mar 26 at 20:34
0
$\begingroup$

I can't point out the exact issue without the blend file. My best guess is that you should check the harden normals checkbox in the bevel or use the weighted normals modifier.

$\endgroup$
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.