2
$\begingroup$

I can make blender 2.79 sit up and beg but I'm coming up to speed on 2.91 and the learning curve is... significant. Today's problem:

I have a model with a UV diffuse texture and I can't get the texture to show up in 3D view. It's just black.

  • 3D view is showing materials, render pass "Diffuse Color". This is working for other meshes in scene.
  • Mesh has a "Principled BDSF" shader with "CGX" and "Christiansen/Burley"
  • Shader has my texture as the base color
  • Texture file shows correctly in the UV editor. UV shows up correctly in Edit mode.
  • Switching the texture to one which is showing up correctly on another mesh has no effect. This mesh still shows up as black.

I've checked the shader in the materials panel and also in the shader editor. It looks right, and it looks the same as the other meshes that are working.

Texture does show if I switch the 3D view to "render" but that's slow and I have another problem which I think this problem is causing, so I have to solve it. (When I bake the texture from this model to another, it shows up black.)

I've run out of things to try. Any ideas?

Screenshot showing the model selected, some other models in the same scene showing correctly, the image that should be shown, and the materials panel.

3D view

Shader editor for the problematic mesh

$\endgroup$
10
  • 3
    $\begingroup$ please show a screenshot $\endgroup$ – Aster17 Mar 25 at 13:00
  • $\begingroup$ Hey :). So the mesh shows any texture as black, but only in Eevee (material preview)? $\endgroup$ – Jachym Michal Mar 25 at 13:23
  • $\begingroup$ Screenshot. Shows model selected in 3d view along with two other meshes which are showing correctly. Shows texture in upper right and material in lower right. $\endgroup$ – Bad Dog Mar 25 at 13:28
  • $\begingroup$ Erm, screenshot coming as soon as I figure out how. $\endgroup$ – Bad Dog Mar 25 at 13:29
  • 1
    $\begingroup$ You specified your material output as Cycles - try changing it to All. $\endgroup$ – Markus von Broady Mar 25 at 14:41
4
$\begingroup$

In hopes this can help not just you but also people finding this thread in future, here's some things to check to better understand the problem:

  • disconnect the image texture from the shader and manually set the base color to see if it's a texture issue at all (in OP's case it isn't)
  • change the background color (World Properties tab ) to see if the issue is black color of the model or transparency:

As for the solutions:

  • in viewport shading settings try deselecting Scene World or selecting Scene Lights:

  • in Material Properties tab make sure Blending Mode is Opaque:

  • in Shader Editor make sure the Material Output is set to All:

$\endgroup$
2
$\begingroup$

Fixing the material output to match what the 3D layer is using per above suggestion fixed the problem.

The image of the Shader Editor above shows that the Material Output node is set to Cycles. But Blender has several render engines, Cycles and Eevee in particular.

In the image of the 3D View above, the view is set to show Materials. (Circle highlighted in blue in the lower right corner). The materials view uses the EEVEE renderer.

So the key is the material output has to match the active renderer in the 3D view. All or *EEVEE * in the Material Output produce an EEVEE output the renderer can use. Cycles, which I had set for no good reason, does not.

$\endgroup$
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.