12
$\begingroup$

How can I change the curve resolution of hair particles? It seems that by default, hair consists of 4 segments. Which is fine most of the time, but for long hair this does not work at all, as in this picture.

enter image description here

The segments spinner at the very top of the particle settings does not accomplish this, contrary to what one would think from the name and tooltip: "Number of Hair Segments".

$\endgroup$
2
  • $\begingroup$ Maybe a bug. I think that used to work. $\endgroup$ – Scalia Jan 2 '15 at 4:21
  • $\begingroup$ I found the same issue, I hope someone has a solution to this $\endgroup$ – VRM Jan 2 '15 at 5:28
12
$\begingroup$

There are three different settings which control this:

enter image description here

  • 3D view > Particle edit mode > Tool shelf > Options > Draw. This setting affects the curve resolution in the 3D view only while in particle edit mode.

  • Properties > Particle settings > Render > Steps This setting controls the number of steps in the final render.

  • Properties > Particle settings > Display > Color This setting controls the number of steps in the viewport, outside of particle edit mode.

The Segments setting at the top of the particle settings controls the number of control vertices there are, however doesn't affect the number of interpolation steps. Think of this like scaling and image up with Nearest interpolation; you end up with more pixels, but the result is not smoothed.

$\endgroup$
3
$\begingroup$

You should also check the influence of the Children settings in the Kink section are different types of periodic offset to choose from:

Increase the frequency slider (number of waves) and adjust the amplitude (strength of waves)

enter image description here

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.