0
$\begingroup$

i've made an armature for my character and parented it to both the shirt and body mesh of my character, but when i pose the character the body mesh pokes through. i don't particularly want to add any physics to my clothing as i'm not going for realism but if there is indeed some physical property or modifier i could use to prevent this, i would love to know. i tried shrinkwrap modifier with .001 offset, but the result was about the same. enter image description here

enter image description here enter image description here

the file, if needed: https://pasteall.org/blend/eed85f2ab37944bb804b230529c633df

thank you in advance!

$\endgroup$
3
  • $\begingroup$ Why don't to delete all hidden part of body that is not visible thanks to cloth? $\endgroup$ – vklidu Mar 24 at 8:10
  • $\begingroup$ i don't really want to destroy the mesh, since i want to put other clothes on the character later... :( $\endgroup$ – leafmaster46 Mar 24 at 8:13
  • $\begingroup$ you can use the Mask modifier in order to hide a vertex group $\endgroup$ – moonboots Mar 24 at 8:14
0
$\begingroup$

You can hide/delete the mesh which is not visible due to clothes or you can adjust the clothes by going into edit mode such that body isn't visible

$\endgroup$
0
$\begingroup$

You can select all the vertices that you want to make invisible and press CtrlG to assign them to a new group, then give a Mask modifier to your object, and in the Vertex Group field, choose the vertex group you've created, press on the Invert button to make the vertices invisible. You can disable the modifier whenever you want if you keyframe its visibility.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.