0
$\begingroup$

I've been trying to fix this forever and I dunno what to do anymore,

I have a plane (over 100k subdivisions)

I set cycles render to experimental (every tut tells me to do so)

now I read that in order for displacement to work you have to change the displacement type in materials settings from bump to displacement and bump (thanks for the default settings which disable functionality?!). I saw that in Blender guru's tutorial.

But when I do that, the Material turns black, I can only use bump only in material settings.

BLENDER FILE: Blend file - displacement bug

All i basically want to do is to displace my ground material i downloaded from quixel megascans.

Every image I see of the quixel megascans looks photoreal, but when i export via bridge they never displace and are flat. So i always have to find a way to displace them, when i do with the displacement modifier it only displaces one the texture i load in, i want to use a bigger plane and use the texture multiple times (using blender gurus poliigon addon).

Does anybody know a good tutorial for ground material + displacement ? I am 100% sure there's gona be a silly problem anyways, so far there wasn't even one tutorial where i could just follow along without any functionality, interface, location, glitch or bug issue.. This is by far the most tiring software i learned (and still learning) hands down. But I won't give up! Sorry just had to let some steam out...

Appreciate your help!

$\endgroup$
3
  • $\begingroup$ the default settings are geared towards the average user, and one of the considerations when using microdisplacement is that there is considerable calculation every time you do anything in rendered view - you can change anything you like and save a new startup file $\endgroup$ Mar 23 '21 at 22:16
  • $\begingroup$ although perhaps that particular option is a per-material setting, so maybe I'm talking out of me arse :D $\endgroup$ Mar 23 '21 at 22:16
  • $\begingroup$ its quite disturbing that such settings, which u can access are avaliable (at least one would think because u can use the nodes and all) but there is one thing somewhere in some window which actually disables it. I mean how on earth am i supposed to know that "yes we put this thing in there, and u can use the nodes and set it up, but its disabled somewhere", really weird design decision. I could still live with that if the entire GUI and functionality wouldn't change so drastically all the time so even if i look up solutions, those aren't up to date neither.. its like a witch hunt sometimes :D $\endgroup$
    – Ozzy
    Mar 24 '21 at 8:39
1
$\begingroup$

Just a few notes to Horyzon's in depth explanation ...

  • for this kind of displacement (on pixel level) you don't need necessarily to subdivide your mesh destructively. You can use simple Plane with four vertices and Subdivision modifier > Adaptive Subdivision feature that does the same job.

enter image description here

  • care about object Scale to be 1 otherwise Displacement node > Scale value has to be Multiplied or Divided when Object Space is set in this node.

enter image description here

  • and as already pointed by Horyzon values are off ... since in your comment you provided another blend file with different setup fail, here is a node setup

enter image description here

BTW I don't see your displacement texture dark (or black) I see it more bright (it could be even darker), anyway it works as it is. You can play with darkening or brightening with this kind of texture, but be careful when you are working with terrain (like satelite) data, even they looks dark they precisely specify under and above sea level.

$\endgroup$
1
  • $\begingroup$ Thank you kind Sir !! $\endgroup$
    – Ozzy
    Mar 25 '21 at 20:45
2
$\begingroup$

Luckily this is a easy one, the only problem was your Displacement node having the wrong values. I downloaded your file and saw that you set the scale on your displacement to something around 47 which is really big, this value controls the overall scale the displacement has meaning a higher value makes the displacement stand out or drop down more.

The middle value called "Midlevel" was set to 5 in your file, but it should be around 0.5 in most cases as it marks the height of the overall displacement (the Midlevel specifically controls what height the colour on your height map right in the middle between black and white would be at, in short its the height of the entire displacement.) Due to it being at 5 in your example, the whole texture got sent up into the air so you couldnt see it anymore, therefore making the object appear invisible because you could only see the orange outline which doesnt go up with the rest of the texture.

Lastly, the displacement texture you're using is almost completely black meaning the texture gets sent down anyways as black indicates a drop in the displacement and white tells it to go up.

I would reccomend you to play around with the displacement node in a test file and learn how the different values work so you can set them up correctly in the future, as well as making your texture artificially brighter so it ideally spans the whole range between black and white, either in a image editing program like Photoshop or using nodes in Blender.

I hope this helps, if it doesn't make sure to comment here again so I can help you further :)

$\endgroup$
2
  • $\begingroup$ Hey, Thanks for the help! So I changed every setting but i didn't expect any changes since you said that the displacement is black, so i opened it up in photoshop and the file has a red tint, but an intense red tint, I would love to show you but It's not allow to answer as a post so i can't attach any pictures in a comment. I took out the saturation and saved again, replaced the displacement map, still flat and it still turns black if i change to displace and bump in material settings. we.tl/t-xKHfVndhEo What am I doing wrong? $\endgroup$
    – Ozzy
    Mar 24 '21 at 8:33
  • $\begingroup$ @Ozzy Why did you connect displacement texture into Normal socket of Displacement node in this case and not to Height as in your Q? Since Horyzon is right I added a few additional notes that was too much for just a comment. $\endgroup$
    – vklidu
    Mar 25 '21 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.