1
$\begingroup$

I'm having a problem here and I hope someone could help me find an answer to it. So, as the title suggests, I'm coming from 3DS Max, relatively new to Blender.

When I finish creating a mesh inside another 3D software, I bring it to Blender for further editing. One of the main things I do is to merge separate parts into one. So, naturally, I use the merge by distance option. And here lies the problem. By giving the exact same distance here and in the weld option in 3DS Max I get different results and sadly - Max handles this better. I'm not really sure how merging vertices by the same distance can give different results but apparently, it does. So my question is: Does anybody know why this happens? If so, can you tell me how to get the same result in Blender?

To further explain the difference: When having a dense geometry and trying to weld-by-distance 2 separate objects, in Max they weld vertex to vertex from one object to the other. In Blender however, if the distance between 2 vertices of the same object is lower than that of the vertex corresponding to it from the other object, it merges them instead. So, in a way, Blender does it as you'd think it should - it merges the 2 vertices that are closer to one another. But in reality, when merging, it would be great if I could somehow "tell" Blender to consider objects when merging and ONLY merge vertices of different objects.

So, to sum it up: I'd like this: enter image description here to be merged like this: enter image description here instead of this: enter image description here

And, while in this simple case the method with scale to middle + auto weld would work, in the case of a more complex geometry, like a Jacket's sleeves for example, this wouldn't work.

If there's no way to do this, I think it should be possible for a script to be created that only merges vertices IF they are not directly connected or if they're not part of the same object (or in Blender's understanding if they're not linked). Also could work by checking if the UV's are connected somehow and only merge vertices of parts that don't have connected UV.

P.S:

I tried the suggestion with the bridge and it doesn't work the way I want it to.. So, as with the Jacket case mentioned above, I'm showing now an example with the bottom elastic of a hoodie.

This is how it looks before bridging: enter image description here

And this is how it looks after that: enter image description here

I tried all connect loops variations and nothing does the job. This is a simple example with just the elastics, but you can imagine what happens with the whole hoodie. So in order for this bridge method to work, I need to bridge loop by loop and that would take forever for something that takes a second in 3DS Max.

$\endgroup$
2
  • 3
    $\begingroup$ Operation to obtain result from screenshot 2 based on screenshot 1 is bridge edge loops with merge option enabled. In blender merge by distance only merges, it doesn't move vertices to any locations except from those they were originally located at (either source or target ones), so result from 2 can't be achieved given what 1 is showing if using merge operator. $\endgroup$
    – Mr Zak
    Mar 22 at 22:24
  • 1
    $\begingroup$ I don't quite understand that the geometry you have from the screenshot. It's looks like you should use merge by distance. If you don't want to merge on every part on the model, just select only parts that you want to merge before doing this. $\endgroup$
    – Crantisz
    Mar 23 at 19:32
4
$\begingroup$

Select vertexes - Edge Ctrl+EBridge Edge Loops (Also available in context menu in edge select mode). Then press F9 to adjust last operation, select Merge.

enter image description here

$\endgroup$
3
  • $\begingroup$ I'm sorry, this method doesn't work for me, I added the reason in the question as a P.S. If you think there's a way to make it work (by changing some of the options for example) please tell me what I can do. Also, thank you for the answer! $\endgroup$
    – Aleks K.
    Mar 23 at 19:16
  • 1
    $\begingroup$ I guess, it doesn't work because you select 4 loops instead of 2 $\endgroup$
    – Crantisz
    Mar 23 at 19:43
  • $\begingroup$ Actually, I select 10+ loops and I get that this isn't the way this tool works, but it's what I need for a one-click - perfect merge solution. Just like Max welds by default $\endgroup$
    – Aleks K.
    Mar 23 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.