2
$\begingroup$

Till half way of my process, all was good. I was able to produce images but now all I get is black images. Checked world environment and lightings too. No luck. Can anyone please tell me what's wrong?

File size: 21.1mb Link: https://blend-exchange.com/b/kjKW8Pwn

What setting I messed up?

$\endgroup$
2
  • $\begingroup$ Could you clarify a few things: what do you mean by half way of your process, you mean that eventually you made some changes which caused the issue? Do you remember what kind of changes you made, to the topology, lightning, output settings, etc. Also what do you mean by black images - I initially thought you mean you get entirely black images, but when I render your project, I get this: i.imgur.com/z451M3v.png - if you get the same result, I find "nothing else" in the title misleading. Perhaps a better title would be e.g. "only half of my character renders and it's very dark" $\endgroup$ Commented Mar 18, 2021 at 9:57
  • $\begingroup$ @MarkusvonBroady Yes. It was appearing but I am not sure what changes I did (because I did many) and image appeared black after rendering. Yes, I do entirely get black image. In the link you shared, I don't see anything. It is plain black. $\endgroup$
    – Jehan
    Commented Mar 18, 2021 at 10:14

1 Answer 1

6
$\begingroup$

Having a bright, high contrast monitor and good vision, I'm able to see this picture is not completely black:

In future, you can try cranking up the Exposure in Render Properties tab -> Color Management section (or use compositor to increase contrast etc.) to see what's happening better:

As you can see, your character is cut in half. This happens because the character is overlapped by an object, which also blocks light, putting everything left in a deep shadow.

Right away when you open the uploaded project, you can see the problematic object on the bottom workspace region:

It's not problematic in viewport preview, because it was set to only display as a bounding box in the viewport:

The solution you probably want is to disable rendering of this object by clicking on a camera icon next to the object's name in the Outliner:

Then the render becomes this:

$\endgroup$
2
  • 1
    $\begingroup$ And the reason it worked for Cycles is Cycles-specific properties of the object: all Ray visibility options disabled in the Object Properties tab. $\endgroup$ Commented Mar 18, 2021 at 10:55
  • $\begingroup$ Thank you so so much for this :) It solved my problem. $\endgroup$
    – Jehan
    Commented Mar 18, 2021 at 11:20

Not the answer you're looking for? Browse other questions tagged .