0
$\begingroup$

How do I extend a short animated walking motion in the Dope Sheet section ? I tried to copy paste the motion key points but the pasted portion returns character from the starting locale point (understandably) ... which would be an additional question .. how to adjust so that it doesn't bring character to starting point. Here is a clip of what I am trying to explain: (https://streamable.com/0525vz)

$\endgroup$
3
  • $\begingroup$ please provide blend file $\endgroup$
    – Chris
    Mar 18, 2021 at 9:34
  • $\begingroup$ I got the animation portion of the model from the Mixamo website and created the model using MakeHuman software. Then imported them into Blender. Here is the download link of the Blender file: (mediafire.com/file/43r1oafh6w0nelg/Walking+Test.blend/file) $\endgroup$
    – Steb
    Mar 19, 2021 at 3:56
  • $\begingroup$ When I encountered this, I used the graph editor to move the frames up. $\endgroup$
    – TheLabCat
    Mar 19, 2021 at 5:02

1 Answer 1

1
$\begingroup$

For this kind of animation (long distance walk) you could use a walk cycle and make the armature follow a curve, but, as ZargulTheWizard says, it is pretty easy to fix in the Graph Editor:

  • First delete the 3 last keyframes (which are identical), select the whole series of keyframes, duplicate them whith ShiftD, move them on the right and keep them selected:

enter image description here

  • Switch to Graph Editor with shortcut CtrltTab, unfold the Armature's tracks on the left, select the track called Z Location (mixamorig.Hips) which is the root bone, and make it the only one visible with a ShiftH:

enter image description here

  • Now move up the handles until it fits with the beginning of the curve (keep pressing Shiftt if you want to move more precisely). Now the character will continue its walk as it should:

enter image description here

$\endgroup$
7
  • $\begingroup$ I didn't see the Armature tracks in graph editor. First screenshot attached is the duplication process and then the second screenshot is what I see in graph editor ... not armature tracks seen. (i2.paste.pics/32726c637320fda3d0bb5748b1c1fc07.png) i2.paste.pics/29f10548c772685bf6706121fdbd4db6.png $\endgroup$
    – Steb
    Mar 22, 2021 at 5:14
  • $\begingroup$ it looks like you've unselected the armature, select the armature again $\endgroup$
    – moonboots
    Mar 22, 2021 at 6:06
  • $\begingroup$ Here is a video clip of the selection of the armatures yet it still doesn't show the armature tracks in the graph editor. (streamable.com/4f2iv2) $\endgroup$
    – Steb
    Mar 22, 2021 at 8:57
  • $\begingroup$ make the armature visible in the Outliner and select it in the 3D view $\endgroup$
    – moonboots
    Mar 22, 2021 at 9:05
  • $\begingroup$ Ok I made it visible ( I missed that ). It runs fine now. But after duplicating that portion to extend the walk, I decided to add another duplicate to further extend the walk but that last 'addition' sort of disabled the animation but the model was still moving. I thought intuitively I would simply add as many duplicates of that walking animation to extend the walk a long as I want. Anyway to fix this ? Here is the video screenshot of what I am talking about: (streamable.com/87l3sq) $\endgroup$
    – Steb
    Mar 22, 2021 at 9:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .