8
$\begingroup$

This question already has an answer here:

Is there any way to make a totally white shadeless material in Blender Cycles? I need to render something as a silhouette being totally white and the background (the background isn't an image or geometry, is just non-existent) completely black.
Or make the geometry totally white with not shadows or lights at all, and the background totally black.

I know that in Blender Render you can simply make a Shadeless object texture by pressing the button with the same name and reducing the reflection of the same geometry.

$\endgroup$

marked as duplicate by Ray Mairlot, VRM, cegaton, user7952, Jaroslav Jerryno Novotny Dec 30 '14 at 18:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

24
$\begingroup$

Here is a node setup for a shadeless material:
Nodes for answer

If you use just an emission shader the object produces light. So it still is not shadeless as it is casting light on other objects. To make it shadeless, you must make sure it sends light only to the camera. To do this, add mix shader with the emission shader plugged in the bottom node socket. Leave the mix shader's top node socket empty (or plug in a holdout shader if the empty socket bothers you). Then plug the is camera ray from a light path input node into the factor of the mix shader.

$\endgroup$
  • $\begingroup$ And the cool thing with this technique is that if you want your material to cast diffuse rays on other objects (for example if the shadeless object has its lighting baked but you want it to behave in the scene like it was a diffuse), you can plug a diffuse at the top and you will get this Global Illumination effect on the other objects, which you couldn't get by simply unplugging boxes in the object's Cycles Settings. Of course you need to plug the albedo in the diffuse, not the baked light. $\endgroup$ – ChameleonScales Jul 14 '17 at 0:58
  • $\begingroup$ On the second shader before the mix you should add a transparent shader, for me if not applied it created shadow on objects that are closer to the element that contains this specific material. $\endgroup$ – andrepazleal Aug 2 '17 at 18:49
2
$\begingroup$

Another solution would be to assign a Holdout material to the object, as well as assign the material a unique Pass Index.

Then in the compositor you can grab the mask from the Pass Index and mix the white via the mask and an Alpha Over node. The holdout is good as it doesn't add colour bounces to the scene via indirect lighting. The object still does cast a shadow though.

Screenshot of setup

$\endgroup$
-1
$\begingroup$

Already fixed it! i just created a new material directly in the node editor of cycles, then erased the first box and replaced it for 'Emission' and it worked! pretty easy if you need a quick solution :)

$\endgroup$
  • 5
    $\begingroup$ Well, in that case your object gives light, sometimes it is problem and you don't want it to do. $\endgroup$ – Adrians Netlis Dec 30 '14 at 12:48
  • 1
    $\begingroup$ NP! Good luck with your future projects!;) $\endgroup$ – Adrians Netlis Dec 30 '14 at 15:11
  • 2
    $\begingroup$ Double check the colour value on the emission shader if you want pure white. The default brightness value on the emission shader is 0.8 not 1.0. $\endgroup$ – Todd McIntosh Dec 30 '14 at 18:04
  • $\begingroup$ Emission of strength 1.0 does not actually emit light into the scene. Not sure where I read that. Give it a try to do a "shadeless" equivalent. $\endgroup$ – beiller Jan 13 '15 at 19:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.