-2
$\begingroup$

As the title says. Basically, if I use an image that is a transparent PNG with an alpha channel as a texture, blender displays the transparent part of the image as black. How do I change this default and make is appear as a transparent image?

Could anyone provide some insight on how to permanently disable this "feature".

$\endgroup$
1
  • 1
    $\begingroup$ I've edited your question to remove the rant. Please refrain from insulting people or using inflammatory language. If this happens again, the question will likely get delete and possibly result in a temporary suspension of your account. Please read the code of conduct for Stack Exchange to understand how this website expects its users to interact with each other. $\endgroup$
    – Robert Gützkow
    Mar 17 at 9:24
4
$\begingroup$

In the material settings, change the Blend Mode to anything other than Opaque.

Alpha

Note that this is EEVEE specific - transparency is handled differently than in Cycles due to how EEVEE approximates lighting (transparency is best left out of the "equation" if it is not needed, hence why it is disabled by default). In the Cycles engine, transparency is enabled by default.

$\endgroup$
2
  • $\begingroup$ Wooohooo! this is the answer. :) Is there any way to stop this from happening by default? $\endgroup$ Mar 17 at 14:38
  • $\begingroup$ Oh, it turns out it just makes the entire image transparent complete, with none of the non-transparent spots showing. There must be one other step needed... $\endgroup$ Mar 17 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.