1
$\begingroup$

I made an animation and when exporting to FBX the animation started shaking, but in blender i have no problem.

Problem FBX in Marmoset Toolbag: https://drive.google.com/file/d/1loDWkOefH95C00tcl_WS7Egwn-8rOaMG/view?usp=sharing

Noproblem Blender render: https://drive.google.com/file/d/1Xj08Ifq4eT7UK76tmDlC5UUnCGDALV2z/view?usp=sharing

Actually in FBX the rendering of the pose is wrong because i reset the rest pose, but the shaking is still here. I can remove a big body shaking from the entire model if I remove parental controls from this orange selected bone that is "keep offset" to the "root" bone. But legs and arms shaking still here, i think problem in inverse kinematics, but i don`t know how fix that. I need your help, blender community.

Blender file: https://drive.google.com/file/d/1gsWaPlQfIdOgoyBwKFSZw9ZWHKZXr4pf/view?usp=sharing

enter image description here

A similar problem: Blender animation not exporting correctly to FBX

$\endgroup$

2 Answers 2

0
$\begingroup$

Game engine have a "sample rate". A base fps when it comes to interpreting animation that will impact how animation is read, compressed, interpolated, and so on.
For example, Unreal Engine samples animation at 30fps by default.

In order to reduce the eventual issues when you animate for a game engine, the first and most important thing is to either animate at the same sample rate, or change the endinge's sample. In UE's case (and quite frankly most game engines anyway): that's 30fps. So your animation should be designed with that in mind. Some studio might sometimes work at 60fps since that's considered to be the base target framerate for the average user's screen. But it's more work to animate at 60 than 30 fps.

Next important thing is, when you export your animation, you need to "bake" every single frame of the animation. Meaning replace every curve interpolation by a solid keyframe. That's what's sometimes called "sampling rate" when exporting. In Blender's case, it is "which every X frames are keyed". Blender is set to one by default, meaning it will key every 1 frame of the timeline, which is usually the optimal way.

If your animation ends up somehow messed up after exporting with such baking, the first thing to do is to try to manually bake your animation yourself using the bake animation operator. You will be able to see and correct any issue.

Simplifying the animation will remove keyframes, you effectively destroy your animation. This option is usually used only when you want to reduce your exported file size, and only when you can't do it in another less destructive way.

$\endgroup$
-1
$\begingroup$

The problem is solved, set the value "simplify" from 1 to 0.1 in FBX export settings.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.