1
$\begingroup$

I have joined the objects but they just won't hold together. In the first image, it's as it should be and on the second once it hits the ground, the objects get separated.

enter image description here

enter image description here

$\endgroup$
4
  • $\begingroup$ Can you show some of your settings please? How did you join the objects? $\endgroup$ – PGmath Mar 16 at 17:08
  • $\begingroup$ Selected the objects (The head, foots, torso etc) and then ctrl + j $\endgroup$ – Daniel Sjöberg Mar 16 at 17:10
  • $\begingroup$ Here is the link: blend-exchange.com/b/5aV0NSMZ This is without doing what you said, didn't really understand... $\endgroup$ – Daniel Sjöberg Mar 17 at 8:18
  • $\begingroup$ It only selected just a part... $\endgroup$ – Daniel Sjöberg Mar 17 at 8:37
1
$\begingroup$

You have joined cubes into one object, but in Edit mode vertices are not merged.

Hower with a cursor above a vertex and hit L (Select Linked) ...

  • your mesh is selected partly - means vertices are not connected. This is the reason why it falls as separated.

enter image description here

  • it should behave like this ... I used Remesh modifier > Blocks to quickly generate merged cubes at similar density like yours ...

enter image description here


BTW - Your topology is too uneven and dense.
Wire density has essential impact on simulation result.

enter image description here

With the same Softbody setup, but low poly resolution ...

enter image description here

Here after Limited Disolve X operator ...

enter image description here


Note: You have to Apply Remesh modifier before simulation, because Softbody sim is calculated first and Remesh after - so it wouldn't be taken into a count in simulation.

$\endgroup$
10
  • $\begingroup$ But how do I connect them like that? In the easiest way? $\endgroup$ – Daniel Sjöberg Mar 21 at 9:58
  • $\begingroup$ Like I wrote - Remesh modifier $\endgroup$ – vklidu Mar 21 at 10:15
  • $\begingroup$ Sorry missed that. Could you send the file after the remesh modifier? Since mine still is messed up after adding blocks. It looks very weird and in edit mode, it still doesn't behave like yours... $\endgroup$ – Daniel Sjöberg Mar 21 at 11:04
  • $\begingroup$ Here is the blend blend-exchange.com/b/lMrKnrAq but as you can see in examples none of this version gives you desired result. I just wanted to answer your Q - Why it fails separated and show how topo matters. How to get proper sim with such object with details like tail or eyes, would be better ask a new one if needed. $\endgroup$ – vklidu Mar 21 at 12:20
  • $\begingroup$ How do I get back the material? Thanks for all the help btw! $\endgroup$ – Daniel Sjöberg Mar 21 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.