I noticed that one of the UVs on my model does not appear the same in the viewport as it does in the final render. The appearance in the viewport is correct, and matches what is shown in the UV editor, but the render is different. This applies to both Cycles and Eevee. The issue is only with one object for some reason. Note: there is only one UV per object.

UPDATE: I gave the objects proper names as opposed to their placeholder names, which were formatted like: HairRemeshedVersion.00X, and now the UVs are fixed? I have no clue why that worked, but it did.

The vertical lines correspond to the vertical direction on the UVs

Viewport (correct)

enter image description here

Render (broken)

enter image description here

Here are some things that I have tried which did NOT solve the problem:

  • Applying transforms
  • re-unwrapping
  • Deleting unused UV maps (there were none)
  • using the texture coordinate node instead of the UV map node
  • Deleting the UV map and then re-adding it

In order to give the character's hair fine details, I use a shader which requires a UV map to give the direction of the hair strands, so it is very important that these UVs work!

  • $\begingroup$ Check for a hidden object in the outliner $\endgroup$ Mar 15, 2021 at 22:52
  • $\begingroup$ @Allen Simpson I Checked for hidden objects, and didn't find anything, but I did notice the hair objects still had my temporary names, such as HairRemeshedVersion.001, and when I changed them to something more appropriate, the problem was gone! I have no clue how that worked, but it did! $\endgroup$ Mar 15, 2021 at 23:15
  • $\begingroup$ That is strange, maybe somebody else knows something $\endgroup$ Mar 15, 2021 at 23:16
  • $\begingroup$ If you found solution please create regular Answer for your Question so others can learn from that. If you still want to know more please attach blend with problematic part of mesh with texture packed. Thank you $\endgroup$
    – vklidu
    Mar 26, 2021 at 20:54

1 Answer 1


How the issue was resolved:

I was able to fix the issue by giving each hair object a new name. The previous objects were named "RemeshedHair.00X" with "X" being incremented every time I created a new object. After changing the names to "Hair front/Hair side/Hair back" the UVs were able to be applied properly.

My hypothesis on the cause of the issue:

I no longer have a copy of the .blend that contains the issue, so I can't say for certain what happened, but I can guess. It might be possible that this issue was just some bug in the way that blender handles it's internal data structures. It might be the case that the UV map was somehow unlinked from it's object in the portion of the structure where rendering data is stored, and renaming the object caused an update to that portion of the structure, resolving the issue.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .